Certificate Manager doesn't store passwords

System: Ubuntu 18.04
Tizen Studio version: 3.0

Tried to create a new profile in Certificate Manager and author certificate, but after closing Certificate Manager and opening it again I found out what passwords was reseted with some unknown gibberfish (I can't see it because of the password field dots). Tried to enter passwords again but it still doesn't want to store them.

I can't run any application in Emulator or physical devices because of this. It always fails with Invalid password for obvious reasons.

.pwd files listed in tizen-studio-data/profiles/profile.xml doesn't exist at all.

There's no errors in program output if running from terminal.

Edited by: Egor Zakharov on 02 Nov, 2018


15 Replies
Egor Zakharov

This MUST be a bug in Tizen Studio 3.0.

I've checked Tizen Studio 2.5 in VM Clone and everything working as expected.

K Johnson

Would you please try to create a new certificate profile deleting the profile which password was done reset unexpectedly?

Egor Zakharov

I'm pretty sure what I've already tried to do that while was investigating what's going on. But I'll try again tomorrow to confirm that.

Egor Zakharov

Confirmed. Even after deleting a profile and recreating it passwords still reseting after closing Certificate Manager. .pwd files listed in profiles.xml are missing. I'm sure they haven't been created at all.

And also, this time I tried on Windows version using another computer. A fresh installation of Tizen Studio 3.0.

a seph

Егор, вы смогли заставить CM сохранять пароли? Вообще запускается приложения на эмуляторе? У меня загрузка упакованного виджета доходит до 6% и виснет намертво?

Egor Zakharov

Нет, не смог. Нет, не запускаются. У меня выскакивает ошибка где-то после 50%, как только требуется цифровая подпись для загрузки на устройство. Про зависания не знаю ничего.

K Johnson

I tried to reproduce the same scenario on my ubuntu 16.04LTS with Tizen Studio 3.0 and I'm not getting such error. I guess, a proper re-installation of Tizen Studio followed by deleting and recreating certificate profiles should work as it worked in this case

Before installation please ensure that you've checked all the prerequisites here

If you still face the problem, you may report a bug on Tizen bug Tracker. Here's a guideline on how to report bugs.

Please share reported bug link here on this post to help other developers to keep track.


I reproduced this issue exactly as the original poster mentioned. Also using version 3.0 of Tizen Studio.


In Windows

Egor Zakharov

Just in case:
This issue is only reproducible on Tizen Studio 3.0. If you downgrade to 2.5, everything should work. But development for 5.0 platform would be unavailable.
To downgrade properly, make a clear uninstall of Tizen Studio (delete all the profiles you can find), use installer for 2.5 and use 2.5 branch in package sources settings and forbid upgrades.

a seph

If you want Tizen Studio 3.0 you may use my kludge:

Changseok Oh

It seems that you have executed "tizen package" command with root privilege by using sudo.

Please check below guide.

1. open a terminal with non root privilege.

2. Run the command "env | grep -i dbus" on your terminal without sudo privilege.

     The output will be of the format:


3. Create a file named ".secret" and place it in ~/tizen-studio/tool/certificate-encryptor

4. Copy the value of DBUS_SESSION_BUS_ADDRESS in the .secret file.







Egor, I had the same problem with certificates passwords and I had to type them in every time I wanted to build project via Tizen IDE.

If your target devices are SmartTV, try to install "Samsung Certificate Extension" via "Extension SDK" tab in Package Manager - it worked for me with Tizen IDE 3.0.

Who knows, maybe it will work for your platform too.


Egor Zakharov

Samsung Certificate Extension was installed from the start. And I don't want to use Samsung certs for now.

Also, after an update, I can't create Tizen certificates now. After clicking the Finish button, dialog window appears for milliseconds and nothing more happens. Certificate is not created and the wizard isn't closed. And you can click that Finish button in the infinite vicius circle, for etenity.


Changseok Oh


This issue was caused by the expiration of author certificate.

We prepared a patch to resolve this issue and will release it today.

Could you check after  update tizen studio 3.1?