Tizen TV - push connect throw SecurityError

Greetings to all,

I made some simple application  from sample in Tizen Studio in order to try Tizen push notification. I followed the guide and added following privilege to config.xml

<tizen:privilege name=""/>
<tizen:privilege name=""/>

  Even though I have privilege when I try to connect to the push service with tizen.push.connect I get SecurityError code 18 saying :

An attempt is made to perform an operation or acccess some data in a way that would be a security risk or a violation of the user agent's security policy.

I tried to use older  Tizen and use with tizen.push.registerService than SecurityError is not observable anymore but I get error

Uncaught TypeError: r is not a function

NOTE: I tried for example to get package info so I  added privilege for and it was working, but for push is the same with or without. Also I sent request and recieved permission for this appId also I got APP KEY.

I am using Tizen 6.5 and Tizen Studio 4.6 with Tizen Web Application Simulator.


Edited by: Jagetic on 25 Oct, 2022


1 Replies
Rachel Gomez

8 Best Ways to Fix Google Chrome Security Certification Error
Change Computer's Date and Time. 
Clear SSL State Cache. 
Clear Cache and Cookies From Google. 
Disable Google Chrome Extensions. 
Use Chrome in Incognito Mode. 
Reset All Chrome Settings. 
Use Chrome Malware Scanner. 
Contact Website Administrator.


Rachel Gomez