Problem manipulating file system


I have been working on an app for Tizen in order to display it in Tizen TVs such as SamsungTV. This app has been developed using JavaScript. I have been able to make it work mostly okay, but one of the core functionalities revolves in being able to cache some images and .txt / .json files in the storage of the device. For this, I have studied the FileSystem API, but I think I'm missing something.

I have tried multiple functions related to tizen.filesystem but they don't work. I explain: while I can access the functions, it appears as if I don't... have any kind of storage? For example, I have used

/* Success event handler */ 
function checkCorruptedRemovableDrives(storages) { 
/* Search for the storages */ 

And this returns me a 0. I have also tried to use tizen.filesystem.resolve, returning me an error similar to "Cannot read property 'replace' of undefined" or something similar. I also have tried to access the files in order to check the structure through the Tizen Studio Device Manager, but also dead end. The File Explorer didn't show any files, folders, directories...

So I'm really stumped.

Oh, also, this is my config.xml file.

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="" xmlns:tizen="" id="http://pavjacko/ReactNativeVanilla" version="0.8.5" viewmodes="maximized">
    <tizen:application id="{{ID}}" package="{{PACKAGE}}" required_version="2.3"/>
    <content src="public/index.html"/>
    <feature name=""/>
    <feature name=""/>
    <feature name="" required="true"/>
    <feature name="" />
    <access origin="*" subdomains="true"></access>
    <icon src="icon.png"/>
    <tizen:profile name="tv-samsung"/>
    <tizen:privilege name=""/>
    <tizen:privilege name=""/>
    <tizen:privilege name=""/>
    <tizen:privilege name=""/>    
    <tizen:privilege name=""/>
    <tizen:privilege name=""/>
    <tizen:privilege name=""/>
    <tizen:privilege name=""/>
    <tizen:setting screen-orientation="landscape" context-menu="enable" background-support="disable" encryption="disable" install-location="auto" hwkey-event="enable"/>


1 Replies
Fierce Druid

Hi Gary,

I'm facing similar problems. I've been trying for days, reading back and forth all API documentation and I just can't wrap my head around this.

Have you found a solution to accesing files in Tizen?