Hosted Web Application Issue - Black Screen on TV
When running our web app on our test TV it always only displays a black screen.  We have tried a hosted web app and a built in web app, and both had the black screen. On the emulator both types of applications work. Our TV is version 3.0, while the only available emulator is 6.5. I don't believe this is the issue because the documentation says hosted applications work on 3.0. We tried downloading the older emulators but they would never even launch. We have created a certificate and allowed all network calls. <access origin="*" subdomains="true"/> I have seen the sample Tizen application run on the TV so I don't believe there is anything wrong with the TV. 
We are unsure what "content-security-policy" we need and have tried a few but none worked. When we run the app on the TV we see that it is able to get the scripts for our hosted application, but they are never executed. The network tab shows the call to our script succeeds, but no logs show up. The first thing our script does is log something to the console. The non-hosted version also never makes this log. This seems to me like we have an issue with our content-security-policy, possibly relating to script-src, but we aren't sure what needs to be done to make it work. 
We also noticed in this document "" that it says we need permission from Samsung to create a hosted application. Does this have to be included in the certificate to run it on the TV? What is the process for getting this approval? We have tried a built in web app, so I assume this isn't our current problem but I could be wrong. We would strongly prefer a hosted application over a built in web application if at all possible. 

<?xml version="1.0" encoding="UTF-8"?>

<widget xmlns:tizen="[no allowed to post]/ns/widgets" xmlns="[no allowed to post]/widgets" id="[our. domain]/AngularTizen" version="1.0.0" viewmodes="maximized">

    <access origin="*" subdomains="true"/>

    <tizen:application id="[ourID].AngularTizen" package="[ourID]" required_version="2.3"/>

    <content src="index.html"/>

    <feature name="[no allowed to post]/feature/screen.size.all"/>

    <feature name="[no allowed to post]/feature/screen"/>

    <feature name="[no allowed to post]/feature/network.ethernet"/>

    <icon src="icon.png"/>


    <tizen:privilege name="[no allowed to post]/privilege/tv.inputdevice"/>

    <tizen:privilege name="[no allowed to post]/privilege/productinfo"/>

    <tizen:privilege name="[no allowed to post]/privilege/"/>

    <tizen:privilege name="[no allowed to post]/privilege/"/>

    <tizen:profile name="tv-samsung"/>

    <tizen:setting screen-orientation="landscape" context-menu="enable" background-support="disable" encryption="disable" install-location="auto" hwkey-event="enable"/>


We have also tried at different points including the following with no success:

    <tizen:allow-navigation>our.domain *</tizen:allow-navigation>

    <tizen:content-security-policy>default-src *; script-src *; style-src *; object-src *;</tizen:content-security-policy>

TV Model Code:  UN43MU6300
Software Version: T-KTMACUC-1310.1 , BT - S
Edited by: Kevin Frost on 12 Aug, 2022