Deploy to emulator or device not working

To start, yes I have researched the issues before posting here. Seems a bit scattered and no good answers.


I have a Gear S3 running

I have put the device in developer mode

I have turned on debuging

I am running the latest version of Windows 10

I downloaded and installed Tizen Studio 2.1

I have Visual Studio Professional 2017 - v15.5.2

I downloaded and installed Visual Studio Tool for Tizen

I installed the Tizen SDK (separate from the one that I guess installs with Tizen Studio)

I used the Tizen Package Manager to install:

  • 3.0 Wearable (0.0.26)
  • 2.3.2 Wearable (0.0.15)
  • Tizen SDK Tools (Version 2.5.32 , Installed Version 2.5.26 - I don't know what the difference is here or if it matters.)
  • Samsung Certificate Extension (2.0.14)
  • Samsung Wearable Extension (1.3.0)

I opened the Certificate Manager and created BOTH Samsung and Tizen certificates.

I have my device connected via wifi through the Device Manager

I created a new Blank App (Xamarin.Forms)

I tried to deploy the unedited app project to the device and received the following error:

  • Failed to install - SDB is not installed, or selected device refuses app install

I went to the Devece Manager and right-clicked the device and selecet "Permit to install applications" and received the following error

  • No certificate profile for permit to install was found in the workspace.....blah blah


Tried multiple times with different certs and combinations of events after much researching.

(By the way, my device doesn't have a home/developer folder listed when selected in the Device Manager)


I tried the emulator. (takes forever to open)

I get 2 pop-ups when starting the emulator:

  • Extra package installation failed. sap must be installed MANUALLY!
  • Extra package installation failed. cert must be installed MANUALLY!

And when I try to delpoy to the emulator, I get the same issues as above even after trying the same "Permit to install applications" stuff

  • No certificate profile for permit to install was found in the workspace.....blah blah


So....any thoughts before I throw all of this off of my balcony?


Edited by: Brad Fic on 10 Jan, 2018


6 Replies
Brad Fic

I just noticed that the target framework for the VS project is Tizen 4.0 with no option to select 3.0 even though I installed the 3.0 stuff through the Package Manager.

Even though I haven't found anything noting this, I assume that Xamarin for Wearable (which is preview) only works with Tizen 4.0. Which doesn't fully explain the problems I'm having based on the error messages, but could be the case. (What framework do you know of that ever gives useful error messages?)

Can anyone verify this is true?

Brad Fic

I guess it is correct:

Brad Fic

Still doesn't explain why I can't get the :Permit to install applications" to work even though I created the certificates.

Peter Wegner


Without reading all your posts deeper...

dotNet is still "Running Gag"... I mean under construction... and NO real devices for normal people available.

Only for R&D and "friends"...

Because they can play and install dotNet also on Tizen 3 devices...

No guarantee they will public publish/release something with Tizen 4...

Because they work also on Tizen 5... maybe meanwhile also on 6 in same time...

I am not sure if in 2018 more luck... for Wearables.. or Mobiles...

btw... Mobiles Z series looks dead now.


Short summary.

Forget Gear S3 with dotNet... for looooooong time.

You can only play on Emulator on PC...


Best Regards

Peter Wegner

"before I throw all of this off of my balcony?"


Yep, I agree.

This is exact this what I would do sometimes... if it came to Tizen """features""" and support...

Whole 2017 they were not able to leave public solution to play with dotNet on Real Devices...

So I expect nothing usefull in 2018...

I will not buy expensive TV... to see Developer support is blocked...


Best Regards

Armaan-Ul- Islam

There's no Doubt that, You won't be able to deploy .NET applications on Gear S3 Running on Tizen 3.0. You explicitly need .NET Support within your device which starts from Tizen OS 4.0


But about the Emulator, I successfully deployed Tizen .NET applications on Tizen Mobile, TV and Wearable Emulators several times.Keep in Mind, You would be able to deploy Tizen .NET application only on Tizen 4.0 Emulators. Install Packages for Tizen 4.0 (Mobile/Wearable/TV along with their 4.0 Emulators ) from Package Manager. (Though It has no relevance with the Error message you're given).