Languages

Menu
Sites
Language
Cant run or debug app on device or emulator but app gets installed

Hi everyone,

I am trying to get started with Tizen development and I installed successfully all components I need for Windows 10 and Tizen.Net development.

Emulator (v.4.0) is running great and can't work with it smoothly.

I tried first to install and run the sample web app using Tizen Studio, which worked great. I could install and run the app in emulator and my device.

Now I wanted to install and run a sample Tizen.NET Xamarin Forms app on device and emulator. For it I created a project in VS using the Tizen templates.

I took template for Tizen 4.0 since the emulator and my watch are this version. 

I also created two certificates, one for samsung for real device and one Tizen for emulator.

Now when I try to debug the app from VS the app gets installed on device or emulator but I can't debug. Also trying to start the app in device or emulator does nothing.

I added to this post the log messages  from log viewer (without Info Level) that I get when trying to start the app in device by touching app symbol.

Log messages txt file: 26101_sm-r760-log.txt

There is a line which might be the problem (since it appears suspicious to me) and I get it in both emulator and device:

Error	4899	4899	CRASH_MANAGER	crash-manager.c: get_sysassert_cs(737) > The sys-assert cs file not found: 

When trying to debug in VS I get this message

I am stuck since 2 days trying to get a simple Tizen .NET app running without effort so I decided to try to get some help here.

I also tried to run the app created by other Tizen 4.0 templates like Blank App (in image above) and also project template Tizen Wearable, where there is only one project created. No of them worked.

Hope someone can give some advice.

Thank you in advance :)

Edited by: Rafael Gomez on 28 Apr, 2019

Responses

2 Replies
Juwon(Julia) Ahn

Hi 

You cannot run Tizen .NET template app on both emulator and device. Right?

Unfortunate, we cannot get information about the issue from the log and also cannot reproduce this issue.

But we can check this issue again if you send us app tpk files and crashdump files by email(email address: tizen.net@samsung.com)

Also, you can create emulator image again and execute .NET application after creating cert file again?

how to create emulator image : Launch 'Tizen Studio Emulator Manager' >> Click '+ Create' button  >> Select 'wearable-4.0-circle-x86 (basic)' and click 'Next' button twice >> click 'Finish' button (https://developer.tizen.org/development/visual-studio-tools-tizen/tools/emulator-manager?langswitch=en)

https://samsung.github.io/Tizen.NET/guides/create-wearableapp/

https://samsung.github.io/Tizen.NET/wearables/create-samsung-certificate-for-samsung-wearables/

Frank Mazannek

Hi,

I had the same problem: app was running on emulator, but not on device (Gear S3 with Tizen 4.0.0.2).

Cause of the problem was that the app was built for target platform "x64" (default setting from Visual Studio project template).

After I switched to "Any CPU" in the project settings, it works like a charm.