Cannot Run Tizen Emulator and Device Managers

I added JAVA_HOME parameter using OpenJDK and installed Tizen SDK but I am not able to run emulator or device manager. I tried on VS 2017 and 2019 both gives me error message below. see the image on the url

Error; couldnt create java machine

Error: a fatal exception has occured. Program will exit

I have disabled hyper-v already. 

What could be the problem?


5 Replies
Changseok Oh


It seems that you have not installed OpenJFX for device and emaultor manager. 

You need to install OpenJFX which is guided to be installed in below link.


Emil Alipiev

thank you for the answer but I have followed that link already and i downloaded OpenJXF from the suggested link and i copied  bin and lib folder from OpenJFX to JAVA_HOME location but problem is still the same. I tried JAVAFX 11.0.2 and 12.0.1 version but both have same error message? what could be the problem? how can i identify? i dont see any logs or similar

Emil Alipiev

your documentation also states that OpenJDK 10 should be installed. maybe that was the problem. Is it a must to use openJDK10 or we can use higher versions like OpenJDK12 because in the article urls arent up to date and neither openJDK 10 nor JavaFX 10 exists but only 12 version?

Emil Alipiev

i have tried with openJDK 12 and JavaFX 12 , error has gone and i can open device manager but i still cannot open/run emulator manager, it doesnt return any error but also doesnt open anything. what could be the problem? i tried both vs 2017 and 2019

Emil Alipiev

ok i am finally able to launch emulator, device and certifacate managers. problem was with openjdk version. Looks like Tizen sdk works only with OpenJDK10 and JavaFX11 together. newer versions of openJDK gives error.