Why do I get "certificate in signature is not valid yet" error?
  1. I had no problem installing and running same application to one of my watch.
  2. Until recently it stopped installing with -12 error code saying "certificate in signature is not valid yet"
  3. Certificate was made correctly considering i have been using it to install to a same device for a while.
  4. When I installed on a different device with new cert, it installed fine.
  5. Finally I tried factory resetting the watch. And it started installing fine with the same cert.

My question is, why is it happening?

And do I have to reset my watch everytime it happens?


1 Replies
K Johnson

According to my understanding, it worked because you re-generated the cert. I don't think that you do need to reset your watch everytime. I would like to suggest you to try following below steps whenever you face such problem.

# Step 1: Delete all the existing certificates.

# Step 2: Set the Correct Date & Time in both device and PC. In your device, Turn on USB Debbuging.

# Step 3: Connect the device, Accept connection request in device end. make sure it's on your connection explorer in Tizen Studio.

# Step 4: Create new Author certificate, Distributor certificate, Add the device, Set the Profile active.

# Step 5: Right click on your device in connection explorer, "Permit to install apps"

# Step 6: Clean, Build & Deploy project.