Unable to generate a certificate

I'm using Tizen Studio 3.0 with JDK 7, 8 or 9 (doesn't work with any of them) and I am unable to generate a certificate using either the Certificate Manager or the CLI. In the certificate manager, the "FInish" button briefly flashes a progress dialog and stops. I've tried using the CLI, but it generates this line of output:


Certificate is not valid for reading.certificate expired on 20190101000000GMT+00:00


The CLI log shows the following exception:


2019-01-01 16:02:01,037 [TRACE] - Current working directory: /Users/jchuah/tizen-studio-data/keystore/author
2019-01-01 16:02:01,439 [ERROR] - Pass a valid PKCS12 structure along with correct password for storing it. org.tizen.ncli.exceptions.UnexpectedException: Pass a valid PKCS12 structure along with correct password for storing it. at at at org.tizen.ncli.subcommands.AbstractSubCommand.runCommand( at at at at


Does anyone have any suggestions?

Edited by: Joon Yee Chuah on 01 Jan, 2019


7 Replies
Joon Yee Chuah

For what it's worth, I was finally able to get this to work through the Certificate Manager by installing the Samsung Certificate extension, creating a Samsuing author certificate, and specifying that as the author certificate. Out of the box, the Certificate Manager by itself doesn't seem to work.

Gavin G

how do you install that extension?

Philippe Elsass

Oh well, same here, even when downloading the latest CLI.

I tried installing the Certificate extensions as indicated here:
but neither the CLI or Certificate Manager UI work.

Philippe Elsass

Ok got it, you really have to go through the process described in the link ( where you select the "create certificate for mobile" process, and you have to go to the end to get the p12.

I wonder if we can just use OpenSSL to generate a self signed p12.

However now something's wonky with the profiles: if I create a profile the password is the same as the p12 path but with extension replaced by "pwd"  ...

Philippe Elsass

The passwords mystery is resolved: now the passwords are stored (at least on Mac) in the Keychain - they were previously just encrypted and stored directly in the profiles.xml.

Daniel Ramirez Guerrero

Just for the record, I had the same issue, I couldn't create the certificate. When I installed the certificate extensions, then I could create a Samsung certificate for wearables but it didn't work on the emulator. I finally found the solution and it is as follows:

  1. Install Certificate Extensions as said by Philippe Elsass:
  2. Generate a Samsung Certificate. It allows you to create an author certificate and a distributor certificate.
  3. Generate a Tizen certificate and when asked for an author certificate on step 2 mark "Select an existing author certificate". Look for the one you created on the previous step and use that.
  4. Complete the process with the rest of information. The certificate profile will get created.
  5. Select it and mark it as the active one.

With this you can deploy your app on the emulator without any more issues.

bro kim

This is time issue in tizen-studio. 

Change your time to before 2019, Then It will be success.

Maybe Samsung Developers in SR will patching this.