Tizen TV 2.4 Extension for Tizen Studio 2.0

Hello. I'm trying to use Tizen Studio 2.0 (CLI only) to build web apps to both Tizen 2.4 and Tizen 3.0 (Samsung Smart TV). However, I could not find an extra repository to download extensions for 2.4 and 3.0. The only option I see is for Tizen 4.0.

Is there a way to achieve this?

Thank you in advance.

Edited by: Gabriel Chittolina on 16 Nov, 2017


20 Replies
Armaan-Ul- Islam


There's a Note regarding your query on Samsung Developers: Samrt TV section.

Tizen Studio 2.x supports TV Extension 4.x or higher.



You can develop Tizen 2.X and 3.X TV applications with the IDEs on Samsung developers Archive:

Gabriel Chittolina

Thanks for the response and sorry about the late reply. I accessed the link that you mentioned, but the download link is not available for 2.4 and 3.0.

Armaan-Ul- Islam

You may download the TV Extension 3.1.2, that should contain packages for 2.X & 3.X development.


Additionally, Rather than Tizen Studio 2.X, I would suggest you to download & Install Previous IDE (For example: Tizen SDK 2.4 Rev8 or Tizen Studio 1.2 )

IDE archive:

Igor Blinnikov


Could you please advice how to install TV Extension 3.1.2? I've downloaded it from

It's a non-executable zip archive and I don't know what to do with it. Do I need to unzip it and copy to some destination?

Thanks in advance!




Andrew Witte

@Armaan 3.1.2_TV_Extension is NOT compatible with Tizen SDK 2.4 (it fails to install). If you try to install it in "Tizen Studio 1.3" it forces you to update to "Tizen Studio 2.0".


Is there a way to install "3.1.2_TV_Extension" without updating to Tizen Studio 2.0?

So far Tizen Studio is the most broken modern IDE I've every used. It feels like a sad joke.

Armaan-Ul- Islam

In that Case, You can turn the force Update off. ( After a fresh Installation )

Tizen Studio > Tools > Package Manager > Configuration > Auto Update > OFF


Andrew Witte

This doesn't work. Please take a look at my solution here as to why.


Search for "Whats wrong with Tizen Studio 1.3 and TV Ext 3.x..." in that post.

Igor Blinnikov

It works. See my response on that thread.

But I'm totally aggree that working with TIzen Studio is the worst nightmare.

Andrew Witte

Nice that was the answer to this simple solution.


Tizen SDK 4.0 supports the previous TV model(2016, 2017...).
You can run the application that you made into tizen sdk 4.0 in the previous TV model(2016, 2017...).

Andrew Witte

I'm testing right now and it doesn't work (how did you get it to work??). You cannot target Tizen 3.x TVs with Tizen Studio 2.0. Only Tizen Studio 1.3 works for me.


You just get the error:


Launching the Tizen application...
# If you want to see the detailed information,
# please set the logging level to DEBUG in Preferences and check the log file in 'C:\tizen-studio-data\ide\logs/ide-20180107_140750.log'.

[Initializing the launch environment...]
    RDS: On
    Target information: UN40MU6290
    Application information: Id(GdJX6z8ynt.BasicUI), Package Name(GdJX6z8ynt), Project Name(BasicUI)
Unexpected stop progress...
(0.181 sec)


Jacek Smith

@Yang Unbong, could you provide a bit more info about your Studio 2.1 installation, and what TV you tried it with?  We are all stuck on the sdb getting 'closed' from various TVs, and it seems to be no one has a clue how to move forward.

@Andrew, the error you are quoting asks you to chase that log file.  In my case (have the same problem), that particular log (ide-2018...log) is empty; however, there is another log file (sdblib-2018...log) that corresponds to the first one.  If you check that file, you will see basically a two forms of the same error.  The 'sdb shell command (XYZ)' returns 'closed'.  I did try to use just the sdb command to give me something like 'ls', but no matter what I try, the sdb is failing with that 'closed' error.  

At the same time (as mentioned in the other thread), I am able to use ...\studio\tools\ide\bin\tizen.bat to push a demo package to my TV (UN40MU6290 - I think 2017 TV with TV-3.0).  That demo app (HelloTizen) works fine on that TV.  Not sure whether it means that Studio builds a proper wgt with a working cert, or rather that tizen.bat does something extra.  However, I didn't install any TV-3.0 SDK/Extensions, and if those are really needed, I would assume that tizen.bat would also fail.

Actually, if you use Device Manager, and do 'Open shell' menu item for your TV, I guess you get zilch as well (I am getting a flash of command prompt - assuming the command failed).  On the other hand, If I try to do 'Permit to install application', I am getting "No certificate profile for permit to install was found in the workspace." error.  I did create my certificate, and Tizen Cert Manager shows it, but maybe somehow it is no good.  If that is the case, maybe this is the root cause for the originally reported error (no properly generated cert -> no sdb communication with the TV -> Studio fails to run/debug apps with 'closed' return code).

Jacek Smith

I did regenerate cert, and Device Manager was successful in executing 'Permit to install applications;' however, still the same problem with sdb - no shell command works.  Does sdb require some environment variables to be set?  I only see 'studio\tools' and 'studio\tools\ide\bin' added to my path.

Andrew Witte
Jacek Smith

Andrew, looking at that thread, I share your frustration.  We have some Amazon FireTV apps, and I thought that I saw hell there, but ...

Actually, I just removed Studio 2.1, and finished downloading 1.3.  I will try once more 2.1, based on your write-up.  Thank you for pointing me to it.


Jacek Smith

So, you actually didn't get S2.1 to work?  

I also tried to install S2.1 on a Mac, but Studio couldn't even start, so gave up on that.

P. Vong

☝ I wrote up this documentation a couple months ago for my internal team on how we solved getting Tizen Studio 1.3 and TV Extensions 3.0 back, but this was just finally published publicly. It's most of the same steps and similar screenshots as what Andrew Witte has already posted, but this includes a few extra details. We've had several dev & qa environments  running for a while now by following the step-by-step instructions, so hopefully this helps anyone else out there that's still struggling with Tizen Studio!

Igor Blinnikov

Hi all,

I've just posted an article how to use Tizen Studion 2.1 and run created app on 2.4-3.0 Platform TV using TV Extension 3.1.2

Jacek Smith

Thank you Igor!  I just followed your blog to get S2.1 to work on Windows box.  Actually, I was also able to create a TV v4.0 Custom project that was also successfully running on TV3.0.  Although, the TV section based samples (lower left selection, where we only see TV v4.0) couldn't be run at all.

I put some summary of what I did in that thread -​

Igor Blinnikov

Thank you. That are interesting observations worth familiarize with.