Galaxy Watch debug connection



I was uisng Samsung Gear S3 for testing my apps. Today I received my Galaxy Watch and it does not get connected as the Gear S3.

I have the watch connected to wifi network and I have the IP address.

I have enabled usb debugging.

But it can not connect to the watch. I can ping the IP address of the watch.

I also tried with CLI command "sdb connect 192.168.254..29:26101"


it seems like my current sdb.exe is not compatible. Where can I find the new sdb ?

It seems 

View Selected Answer


3 Replies
Mark as answer
Armaan-Ul- Islam

# Toggle Bluetooth On/Off & test in both cases.

# Download latest Tizen Studio 3.0 from Tizen Developers Site.

# Update All relevant Packages from Package Manager. (For Example: Tizen Wearable 4.0, Samsung Wearable Extension, etc...)

mekabe remain

turning off bluetooth solved the problem.

but why ?

I didn't have problem with my old S3 and S2 connecting while BT was on.


mekabe remain

after the first connection with BT off, now it can connect even when BT is on