Error found when building signed package using Tizen Studio 2.1

Just installed Tizen Studio 2.1 and migrated existing author/distributor certificates using certificate manager.


Encountered error when buidling a signed native app package. It said something like "no certificate profile is found" and asked to run certificate manager which is done already.


Some background information. Using Tizen Studio 2.1 on Windows 10 and building wearable native app for Tizen 3.0. The existing certificates have been used to build wearable native app for Tizen 2.3 using Tizen Studio 2.0.


Any suggestion is welcome! Thanks in advance.



14 Replies
Marco Buettner

I had the same issue with one application, all other application works... I had a image named "jäger.png" ... After I rename it to "jaeger.png" I was able to build the project. Maybe you have to check your application for special chars or something in your files.

V Wong

Similar problem found when select "Permit to install applications" in Device Manager.


No certificate profile


V Wong

V Wong

Screen cap.

Marco Buettner

Create an application based on BasicUI template and check if you can install this.

V Wong

The problem seems fixed by uninstalling everything and reinstall again. Cannot figure out what's wrong actually.


Still, cannot run "Permit to install applications" but signed package can be built and run in my watch now.



Iqbal Hossain

hi Wong, You can run "Permit to install applications" option from Device Manager. 
Go to Tools>Device Manager

V Wong

Finally fixed by creating new author certificate (using existing keys) and distributor certificate. :(

Hex Chang
Hi wong, the same problem occur to me, could you show me every step in detail you solve the problem? Thank you very much./
Iqbal Hossain

hi Hex Chang, Please share detail of your problem ...  

V Wong

Sorry that my SSD died last week and I need some time to install everything.


Back to the question. What I did to fix the problem is:

1. Backup certificates/keys/projects, etc. and then uninstall Tizen Studio

2. Reinstall Tizen Studio and packages (wearable 3.0, certificate and wearable extensions); please note the "default data directory"

3. Run certificate manager to create new author certificate by importing existing author key, and also new distributor certificate

4. Copy existing project directories to the new "default data directory"

5. Import the copied projects

After that, I can create signed package and run "permit to install applications" without problem.

Hope this will help!

Brian Mouton

I'm experiencing this exact problem everytime I try to build a signed package. I've already tried deleting my certificates and recreating them. My app is very far along, I'd like to test on some actual hardware, and this problem is holding me back. I've also tried reimporting my project with little benefit. Is there something I can reset IN the project to fix this?

André Reus

Hi Brian, please follow the suggestions given by V Wong. Hope, these will solve your problem. 

Brian Mouton

Thanks Andre. Ultimately uninstalling Tizen Studio and recreating my workspace fixed the problem.