Languages

Menu
Sites
Language
EDC editor is not starting on Ubuntu 17.04

I'm not sure about the root cause, but it seems like libxcb bundled in efl-tools is incompatible with 17.04's libX11 (1.6.4)

IDE doesn't throw any error messages, edc editor just not starting. So I've tried to run it from shell:

$ LD_LIBRARY_PATH=./tools/efl-tools/lib:./tools/edc-editor/lib tools/edc-editor/bin/enventor 
> monitor dir /home/lev/.elementary/config/standard
> tools/edc-editor/bin/enventor: symbol lookup error: /usr/lib/x86_64-linux-gnu/libX11.so.6: undefined symbol: xcb_wait_for_reply64

Removing bundled libxcb solves the issue:

> $ mv ./tools/efl-tools/lib/libxcb.so.1 ./tools/efl-tools/lib/libxcb.so.1.bak
Edited by: Lev Popov on 19 Sep, 2017

Responses

2 Replies
Shaswati Saha

Thanks for sharing information about the way you've solved the problem. It'll help other developers to save their time. You may share the problem and solution in detail if you want. Moreover, you may add [ solved ] tag into the headline of the post so that others can easily findout and understand. 

Andriy Lesyuk

Thank you, Lev!