Couldn't Install Tizen Studio on Mac OS BigSur


When I tried to install Tizen Studion on Mac OS BigSur, I don't see the installer screen coming up despite I provided sufficient privileges to install.  

I tried with the binary file as well but getting the below error. Any help would be highly appreciated.




(base) Admins-MacBook-Pro-38:Downloads budigam.nagaraju$ ./web-cli_Tizen_Studio_4.1_macos-64.bin --show-license
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsatisfiedLinkError: no nio in java.library.path
at java.lang.ClassLoader.loadLibrary(
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at sun.nio.fs.UnixNativeDispatcher$
at sun.nio.fs.UnixNativeDispatcher$
at Method)
at sun.nio.fs.UnixNativeDispatcher.<clinit>(
at sun.nio.fs.UnixFileSystem.<init>(
at sun.nio.fs.BsdFileSystem.<init>(
at sun.nio.fs.MacOSXFileSystem.<init>(
at sun.nio.fs.MacOSXFileSystemProvider.newFileSystem(
at sun.nio.fs.MacOSXFileSystemProvider.newFileSystem(
at sun.nio.fs.UnixFileSystemProvider.<init>(
at sun.nio.fs.BsdFileSystemProvider.<init>(
at sun.nio.fs.MacOSXFileSystemProvider.<init>(
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
at java.lang.reflect.Constructor.newInstance(
at java.lang.Class.newInstance(
at sun.nio.fs.DefaultFileSystemProvider.createProvider(
at sun.nio.fs.DefaultFileSystemProvider.create(
at sun.misc.Launcher$AppClassLoader.getPermissions(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
at sun.launcher.LauncherHelper.checkAndLoadMain(
(base) Admins-MacBook-Pro-38:Downloads budigam.nagaraju$ 


19 Replies
Ignacio Fuentes

I have the same problem.
I have a MacBook Pro with macOS Big Sur 11.2.3 and java version 1.8.0_281.

Any update for this issue?

Pablo Alba


I have the same issue, MacBook Pro with macOS big sur 11.3.1 and java version 1.8.0_291

Any update for this issue?

sangwook lee


I am not sure that is in my case.

like you, I did not launch TizenStudio 4.1 IDE on Big Sur 11.4 version, too.

But I used that cli installer like the one below that.

chmod +x ./web-cli_Tizen_Studio_4.1_macos-64.bin
./web-cli_Tizen_Studio_4.1_macos-64.bin --accept-license $TIZEN_STUDIO_PATH
Ex) Install mobile 6.0)  => $TIZEN_STUDIO_PATH/package-manager/package-manager-cli.bin install MOBILE-6.0 -r -d official --accept-license


And then, I can use IDE, Emulator, and so on in the Big Sur version,  too.

Could you use that commands, too?


In order to install the extension, you can use that commands, too.

1) Ex) Show Command package lists: ./package-manager-cli.bin show-pkgs
2) Ex) Display Samsung Certificate Extension: ni  cert-add-on   2.0.54  Samsung (ni: not installed)
3) Ex) Install command Samsung Certificate Extension: ./package-manager-cli.bin install cert-add-on --accept-license

With --help command like " ./package-manager-cli.bin  --help" , you can see other commands or sub-commands/options.



You can refer to a similar solution on



Damon McMahon

You can check out You may refer to a solution that is very similar to this one on this article.

Damon McMahon
Linda Lim

Check your security settings to make sure that your Mac is set to allow installations from unidentified developers. You can do this by going to System Preferences > Security & Privacy > General, and selecting "Allow apps downloaded from: Anywhere".


jack nelson

I will try it

jack nelson

Technical support can help I had a problem with a Mac, it turned out that I have a problem with the Internet connection This is quite a convenient service thanks to which you can solve many problems