Languages

Menu
Sites
Language
The CLI installer (v3.3) is failing on Azure DevOps

I have been having some issues with getting Tizen Studio installed on CI. I have the bits working locally, so it is a bit hard to diagnose.

As part of my build process, I run 2 scripts: install OpenJDK and then install Tizen:

The packages I am trying to install are just the 4.0 bits: "MOBILE-4.0,MOBILE-4.0-NativeAppDevelopment"

 The macOS build stopped working a few months ago, but wasn't able to fix it so I disabled it. It works on my local mac. The error is a bit vague:

Install destination is '/Users/vsts/tizen-studio'...
Downloading SDK to '/Users/vsts/tizen-temp/tizen-install.bin'...
Installing SDK to '/Users/vsts/tizen-studio'...

Installation information
    * License Agreement : true
	* Install directory : /Users/vsts/tizen-studio, Validation [true]
	* Data directory    : /Users/vsts/tizen-studio-data

Destination directory : /Users/vsts/tizen-studio

Installer will install to =>  /Users/vsts/tizen-studio

Preparing installation...
...
...
Installation has been completed!
Thank you for using Installer
Installing Additional Packages: 'MOBILE-4.0,MOBILE-4.0-NativeAppDevelopment'...
Package Manager (0.4.38)

****************************************
******* Start to update packages *******
****************************************
Nothing to update.

****************************************
****** Start to install packages *******
****************************************
Under packages will be installed.
     * Emulator
	 * MOBILE-4.0-Emulator
	 * NativeToolchain-Gcc-6.2
	 * NativeCLI
	 * MOBILE-4.0-NativeAppDevelopment-CLI
	 * Certificate-Manager
	 * WebIDE
	 * MOBILE-4.0-WebAppDevelopment
	 * MOBILE-4.0-WebFramework-TAU-CLI
	 * MOBILE-4.0-WebFramework-TAU
	 * NativeIDE
	 * MOBILE-4.0-NativeAppDevelopment
[Emulator] 
0% [----------------------------------------] 100 %
   [+++++++++++++++++++++++++++++++++++++++org.tizen.manager.exception.UMException: Cannot install the Tizen Studio package.
**   Error  **
Installation has been failed.
##[error]PowerShell exited with code '1'.

The Windows installation also just started to fail. I haven't actually changed the script, but I was touching the yaml. It is a different error, but seems to not be able to find java.exe. I do run, in the same script file, a java -version and that is fine. The error is:

Install destination is 'C:\Users\VssAdministrator\tizen-studio'...
Downloading SDK to 'C:\Users\VssAdministrator\tizen-temp\tizen-install.exe'...
Installing SDK to 'C:\Users\VssAdministrator\tizen-studio'...
'java' is not recognized as an internal or external command,
operable program or batch file.

If I run the build loads of times and maybe just randomly add comments, the builod may start working again.

The build I am trying to work on is here: https://dev.azure.com/xamarin/public/_build/results?buildId=4687&view=results

Responses

1 Replies
Matthew Leibowitz

This may be related to something in Azure, so I have an issue there too: https://developercommunity.visualstudio.com/content/problem/661596/the-updated-path-doesnt-kick-in.html