Cannot start an emulator of tizen TV on MacOS (Catalina)

I've installed Tizen Studio, all sdk-s from both Main and Extension tabs.

In the emulator manager I've created default samsung TV emulator, but it's not starting.


MacBook Pro (Retina, 15-inch, Mid 2014)

2.2 GHz Quad-Core Intel Core i7

16 GB 1600 MHz DDR3

Intel Iris Pro 1536 MB

macOS Catalina - 10.15 (19A603) 


The logs I've found:

22:17:33.100| 6684|I|      main| 345|Start emulator...
qemu args: =========================================
"/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator/bin/emulator-x86_64" "-drive" "file=/Users/alex/tizen-studio-data/emulator/vms/t-0103-1/emulimg-t-0103-1.x86,if=none,index=0,,id=drive" "-device" "virtio-blk-pci,drive=drive" "-drive" "file=/Users/alex/tizen-studio-data/emulator/vms/t-0103-1/swap-t-0103-1.img,if=none,index=1,id=swap" "-device" "virtio-blk-pci,drive=swap" "-enable-hax" "-device" "vigs,backend=gl,wsi=vigs_wsi" "-device" "yagl,wsi=vigs_wsi" "-smp" "4" "-m" "1024" "-device" "maru-virtual-tuner,system=ATSC,country=USA,table=/Users/alex/tizen-studio-data/emulator/vms/t-0103-1/tuner_default.cfg,stillimg=/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator-resources/images,wsi=vigs_wsi" "-net" "nic,model=virtio" "-net" "user" "-chardev" "file,path=/Users/alex/tizen-studio-data/emulator/vms/t-0103-1/logs/emulator.klog,id=con0" "-device" "isa-serial,chardev=con0" "-device" "virtio-serial" "-L" "/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator/data/bios" "-kernel" "/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator/data/kernel/bzImage.x86" "-append" "vm_name=t-0103-1 video=LVDS-1:1920x1080-32@60 dpi=72 clocksource=hpet consoleblank=0 http_proxy= https_proxy= ftp_proxy= socks_proxy= host_ip= console=ttyS0 model=4ksero yagl=1 force_pat" "-device" "virtio-maru-tablet-pci" "-device" "virtio-maru-esm-pci" "-device" "virtio-maru-hwkey-pci" "-device" "virtio-maru-evdi-pci" "-device" "virtio-maru-motor-pci" "-device" "virtio-maru-keyboard-pci" "-rtc" "base=utc" "-M" "maru-x86-machine" "-soundhw" "all" "-usb" "-vga" "none" "-device" "maru-external-input-pci,stillimg=/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator-resources/images,wsi=vigs_wsi" "-display" "maru_qt,rendering=onscreen,resolution=1920x1080,dpi=72" 
22:17:33.101| 6684|I|      main| 348|qemu main start...
22:17:33.106| 6684|I|emul_state| 733|initial display resolution: 1920x1080
22:17:33.106| 6684|I|qt5_consol| 171|display density: 72
22:17:33.209| 6684|I|qt5_supple| 515|* Qt version (compile time): 5.6.0
22:17:33.209| 6684|I|qt5_supple| 516|* Qt version (runtime): 5.6.0
22:17:33.209| 6684|I|qt5_supple| 517|* working path: "/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator/bin"
22:17:33.209| 6684|I|qt5_supple| 518|* binary path: "/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator/bin"
22:17:33.209| 6684|I|qt5_supple| 519|* Qt plugin library path: ("/Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator/bin")
22:17:33.218| 6684|I|qt5_consol| 153|Display Type: QT5 Onscreen
ram_size 0x40000000
22:17:33.226| 6684|I|      main| 157|* Board name : Maru
22:17:33.226| 6684|I|      main| 158|* Package Version:
22:17:33.226| 6684|I|      main| 159|* Package Maintainer: Yeonseok Choi <>
22:17:33.226| 6684|I|      main| 160|* Git Head : 
22:17:33.226| 6684|I|      main| 161|* 
22:17:33.227| 6684|I|      main| 162|* User name : Alex
22:17:33.227| 6684|I|      main| 163|* Host name : Alexs-MacBook-Pro.local
22:17:33.227| 6684|I|      main| 166|* Build date : 2019-11-04 16:14:44 IST
22:17:33.227| 6684|I|      main| 175|* Current time : 2020-01-03 22:17:33
22:17:33.227| 6684|I|      main| 179|* Host Qt version : 5.6.0
22:17:33.227| 6684|I|    osutil| 109|* Mac
22:17:33.227| 6684|I|    osutil| 110|* LibPNG Version : 1.6.21
22:17:33.227| 6684|I|    osutil| 113|* Host machine uname :
22:17:33.227| 6684|I|    osutil| 118|* Host machine uname : Darwin Alexs-MacBook-Pro.local 19.0.0 Darwin Kernel Version 19.0.0: Wed Sep 25 20:18:50 PDT 2019; root:xnu-6153.11.26~2/RELEASE_X86_64 x86_64
22:17:33.227| 6684|I|    osutil| 132|* Machine model : MacBookPro11,2
22:17:33.227| 6684|I|    osutil| 141|* Machine class : x86_64
22:17:33.227| 6684|I|    osutil| 100|* Number of processors : 8
22:17:33.227| 6684|I|    osutil| 159|* Total memory : 2147483648 bytes
22:17:33.227| 6684|I|net_helper| 178|Emulator base port is 26100.
22:17:33.227| 6684|I|net_helper| 715|start sdb noti server thread.
22:17:33.227| 6684|I|net_helper| 740|success to bind port[] for sdb noti server in host 
22:17:33.227| 6684|I|      main| 239|kernel commandline : vm_name=t-0103-1 video=LVDS-1:1920x1080-32@60 dpi=72 clocksource=hpet consoleblank=0 http_proxy= https_proxy= ftp_proxy= socks_proxy= host_ip= console=ttyS0 model=4ksero yagl=1 force_pat sdb_port=26100, vm_resolution=640x384
22:17:33.280| 6684|I|      vigs| 159|vigs_gl_backend_cgl_check_gl_version:159 - Using OpenGL 3.2
22:17:33.282| 6684|I|      vigs|2671|vigs_gl_backend_init:2671 - Current GL_VENDOR = Intel Inc.
22:17:33.282| 6684|I|      vigs|2673|vigs_gl_backend_init:2673 - Current GL_RENDERER = Intel Iris Pro OpenGL Engine
22:17:33.282| 6684|I|      vigs|2675|vigs_gl_backend_init:2675 - Current GL_VERSION = 4.1 INTEL-14.0.69
22:17:33.288| 6684|I|      vigs| 536|vigs_device_init:536 - VIGS initialized
22:17:33.290| 6684|I|      yagl| 200|[0/0] yagl_egl_cgl_get_gl_version:200 - Using OpenGL 3.2
22:17:33.293| 6684|E|      yagl| 394|[0/0] yagl_egl_cgl_pbuffer_surface_create:394 - CGLCreatePBuffer failed: invalid drawable
emulator-x86_64: -device yagl,wsi=vigs_wsi: Device initialization failed
22:17:33.293| 6684|I|qt5_msgbox|  69|qt5_msgbox starts... 
22:17:33.293| 6684|I|qt5_msgbox|  63|qt5_msgbox path : /Users/alex/tizen-studio/platforms/tizen-5.5/tv-samsung/emulator/bin/qt5_msgbox
22:17:33.294| 6684|I|net_helper| 704|shutdown sdb notification server.
22:17:33.295| 6684|I|      main|  91|Exit emulator...


Any ideas?


Edited by: Alex Alex on 03 Jan, 2020


5 Replies
Pierre-Olivier Bouteau

I've the exact same issue, I just downloaded and installed the tv sdk and same error.

Jorge Miguel

Same issue here on macOS Catalina v10.15.2. Please advise.

Jorge Miguel

Same issue here on macOS Catalina v10.15.2. Please advise.

Alex Alex

I've created, let's see....

sangwook lee

Hi, Alex Alex,

Thanks for asking it here.

First, we tried to reproduce it in our pc but we can't see it here.

Second, we are guessing that you have somthing wrong in your java env.

In order to use Tizen SDK on VS for Mac, you need to prepare JAVA env in your pc.

In case of not starting the emulator before, they had wrong situation about java env. After correction it, it was fixed.

Could you check your java environment?

We provide  the below guide as a prerequisite for JAVA.
•Oracle Java Development Kit(JDK) 8 and Java for OS X 2015-001
•OpenJDK 12 and OpenJFX: OpenJDK and OpenJFX Installation Guide. 

If it is not related to java or any questions, please update it again here.


Sangwook Lee