Languages

Menu
Sites
Language
Cannot Open Emulator Manager

I installed Tizen Studio 3.3 and Open JDK 10 (64-bit versions), I did everything according to the instructions - https://developer.tizen.org/development/articles/openjdk-10-and-openjfx-installation-guide

The IDE works - it was possible to compile and run an example on the emulator (for example, Calculator). But I can not start the Emulator Manager, I get an error message - The application was unable to start correctly 0xc00007b.

How to solve this problem?


P.S. Updates in the Package Manager installed.

Responses

18 Replies
Karthik Bhat

Hi Marat,

Could you please let us know if the JAVA_HOME and PATH environment variable were set?

Also i hope OpenJFX  bin and lib was copied to bin and lib folder of OpenJDK?

 

If you share the above we will be able to guide you better.

Thanks and Regards

Karthik Bhat

PATRICK LYSAGHT

I am having the same issue, and frankly, have been trying to merely install/set up Tizen all day.  This is ridiculous, I have never had this much difficult with an SDK and IDE before.  I first tried installing the visual studio route.  I installed the extension, created a sample project, tried to run the tizen emulator and received a pop up (windows 10) asking if the emulator-manager.exe had permission to make changes...when I select yes, nothing happens.  I have tried this several times.

After giving up on that route, I gave the Tizen standalone IDE a whirl.  I installed, and started a sample project.  When I tried to run the sample project, Tizen said it couldn't locate google chrome AAAAAAAAAAAHHHHHHHHHHHHHHH!!!!!   So frustrating.  I gave up on that and went back to visual studio.

I followed the install instructions, updated my JDK and environment path, tried intstalling and uninstalling several times.  Nothing works.  

To pinpoint an issue, however, it seems to be the emulator-manager.exe not doing anything upon running, or if I select the tizen emulator manager from the tools dropdown section.   I have verfied that all of my paths are correct under the Tizen options, and have navigated to the emulator-manager.exe in the actual folder, tried to run as administrator, and still nothing.

Please help!!!

Thanks,

Patrick

Rahul Dadhich

Hi Patrick,

Can you please share the tizen studio version installed in your system?

Can you please let us know the JAVA version installed and JAVA_HOME path value.

 

Thanks,

Rahul

 

 

PATRICK LYSAGHT

C:\Program Files\Java\jdk-12

I have also tried a few different versions of java jdk, none of which worked.

Tizen Studio 3.6

I would ideally like this to work on visual studio and not have to rely on Tizen Studio.   Again, my main issue is that the tizen emulator manager won't work on visual studio.

Rahul Dadhich

Hi Patrick,

 

Did you install JAVAFX  ?

You can follow https://developer.tizen.org/development/articles/openjdk-and-openjfx-installation-guide link for steps.

Also can you please try to launch device manager and update the status, if you are able to launch that?

 

Regards,

Rahul

PATRICK LYSAGHT

I installed openjfx and that doesn't work.  I decided to try going the Tizen Studio 3.6 ide route again, and firstly, I receive the following error when trying to download the program from my work network:

Gateway Anti-Virus Alert
 
This request is blocked by the Firewall Gateway Anti-Virus Service. Name: MalAgent.J_65286 (Trojan) blocked.

I can only download it from my home network, good grief.  

Anyway, I installed Tizen Studio, opened the package manager, installed the Tizen SDK tools and everything included in that package.  When opening Tizen Studio, the package manager, dynamica analyzer, and certificate manager work fine but the emulator manager and device manager won't open.  I click on it, and the nothing happens.  I have also installed the 5.5 and 5.0 wearable devices and emulators and ensured that the emulator manager has been installed as well within the Tizen SDK tools package.

If I try to open the emulator manager directly from its file location, and run as administrator, same thing: nothing.

Rahul Dadhich

Hi Patrick,

 

Can you try to execute below command on command prompt?

"<java installation path>/bin/javaw" --module-path="<java installation path>/lib/javafx.graphics.jar;<java installation path>/lib/javafx.controls.jar;<java installation path>/lib/javafx.fxml.jar;<java installation path>/lib/javafx.base.jar;<Tizen Studio Installation path>/library/jaxb-ri/" --add-modules=ALL-MODULE-PATH -XX:+IgnoreUnrecognizedVMOptions -jar "<Tizen Studio Installation path>/tools/emulator/bin/em-ui-3.0.jar"

if this also doesn't work, request you to please verify if below files are available at path:

<java installation path>/lib/javafx.graphics.jar

<java installation path>/lib/javafx.controls.jar

<java installation path>/lib/javafx.fxml.jar

<java installation path>/lib/javafx.base.jar

<Tizen Studio Installation path>/library/jaxb-ri/

 

Regards,

-Rahul

PATRICK LYSAGHT

No luck.  The files you references are all available.  I have, however, gotten the emulator to work with Tizen studio and have been able to start testing some things.  Just can't open the emulator manager.

Rahul Dadhich

Hi Patrick,

 

I am just trying to identify what needs to be corrected to launch emulator manager.

Can you please share the result after executing above command from command line?

 

Regards,

-Rahul

Joshua Lamour

So I was going through the same issue and troubleshooting you're describing and checked to see I was using jdk-12.0.1 as my JAVA_HOME path. I went through the Tizen Studio Prerequisites page and it suggests using JDK 8 or OpenJDK 12 with Tizen Studio 3.5+. Anyways I finally got Emulator Manager working once I installed jdk-1.8.0 and switched my JAVA_HOME to that. The links to JDK 8 can be found on the Prerequisites page

bac

I too am having issues with the IDE and (mostly) the emulator, but not exactly the same.

 

With the tizen/ecipse IDE, everything broke when I started updating. Especially with java. Even after I finally rolled back to the advised version (1.8.0_201, 64 bit) the latest IDE wouldn't run. I had to uninstall  that version (and manually find and remove a lot of files in various parts of my system), then install the previous version, then manually create a new project and and add each source into the new project. Finally, after many hours,  I got the IDE to load/build/debug previous projects that I had working before.

 

As for the emulator, I had to uninstall, and re-installed, all versions, along with the sdk, from the package manager (at least that was working for me). Though I can build any/all wearble versions (2.3.2 - 5.5),  I can only run the 2.3.2 version emulator. All of the others start up - the watch window shows up, and some lines are displayed about linux booting up. But then nothing. I can let that continue for hours and still nothing. I don't even know where to look for any log files, if there are any. Again only the 2.3.2 version works (actually, this has been the case for a long time).

 

I also tried to get Visual Studio extensions running. I can create a project (ui with edc), but cannot build it. I get an error about missing some import files.

 

I am mentioning all of this now as I am very frustrated with all of the tizen products. It took me several months just to build a replica of a simple watch I had made in GWD. And then, after what should have been a simple java upgrade, everything broke. Big time. How can I be expected to build anything for tizen without any working tools? Okay, I could just use eclipse to cross complie and build my project, then use sdb to install that to my (real) watch, and hopefully nothing breaks and gdb will remotely debug it. :-(

Just REALLY frustrated.

 

ken

 

 

 

 

Rahul Dadhich

Hi Ken,

 

Can you please confirm few things?

Host OS,

Tizen Studio Version installed

For Emulator issue: Can you please if CPU VT is enabled, if not please enable this and try to relaunch.

You can find logs under tizen-studio-data folder, please share the logs as well so that we can look into this.

 

Can you please let us know which project you are creating in Visual studio and what error are you getting on building that?

 

Regards,

Rahul

FWIW after Java updated and broke my tizen emulator, I found the JAVA_HOME in System variables path being left at a now invalid version/path.

just updating this value to the latest installed path fixed my ability to launch the emulator.

Aditya Aswani

Tizen Studio 3.6 depended on JAVA_HOME env variable to launch various tools.

Can you please try with the latest Tizen Studio 3.7 available at https://developer.tizen.org/development/tizen-studio/download

There is no prerequisite for Java in this version of Tizen Studio. You can remove any java installation and java related env variables in your system if not used by any other application.

Tiny Titles

I had the same trouble with launching "Emulator Manager". After hours of playing around with different Java version I finally got it working. Next thing was to use a real watch and not the emulator. Debugiing on real devices fails due to a missing certificate. Okay, it should be fixable with the "Certification Manager" right? Low and behold that thing want launch and just fails quietly like my "Emulator Manager" did multiple hours ago.... I am done for the day...

Egon Steiner

I'm also had some problems opening the emmulator manager. When I tried to start the emmulator manager through the Studio nothing happens. It would be nice to at least have some kind of error handling to get a message to help narrow the problem down.

I tried starting it through the console. There I got the following error:

Error: Could not find or load main class org.tizen.emulator.manager.ui.Main
Caused by: java.lang.NoClassDefFoundError: javafx/application/Application

Seems like JavaFX is not installed and clear instructions on how to install it are hard to find.
I downloaded the sdk from here: https://gluonhq.com/products/javafx/

I unziped it and copied the contents to the lib folder in my JAVA_HOME now everything seems to work.

I hope this helps some people to get it to work.

Aditya Aswani

Seeing the error log I assume you have installed openJDK with FX libraries missing.
 

Can you please try with the latest Tizen Studio 3.7 available at https://developer.tizen.org/development/tizen-studio/download

There is no prerequisite for Java in this version of Tizen Studio. You can safely remove Java from your system if not used by any other application

Aditya Aswani

 

Hi, can you please try with the latest Tizen Studio 3.7 available at https://developer.tizen.org/development/tizen-studio/download

There is no prerequisite for Java in this version of Tizen Studio.
This should resolve the JDK setup issues that you are facing.