stt_create error -13 : PERMISSION DENIED


I'm developing an app that use STT.

and I'm so painful that My app could't create stt handle becouse of error code -13 (permission denied).


I followed contents of TIZEN guide in developer page.

 1. I included header file (#include <stt.h>)

2. for satisfing prerequisite of stt_create,I made certification that has public privlevel.

3. in TIZEN menifest editor, I added recorder privilege.   

But whenever checking log,  error code is same.

Give me a help if you know how to solve this problem...



/*create_stt_handle function*/

create_stt_handle(appdata_s *ad)
    stt_h stt;
    int ret;

    ret = stt_create(&stt);

    if (STT_ERROR_NONE != ret)
    dlog_print(DLOG_INFO, "CMS", "%s err = %d", __func__, ret);    // Log result : create_stt_handle err = -13
    else {
    return stt;




안녕하세요. STT 기능을 이용하는 앱을 개발하고 있는 학생입니다.

stt_create 함수를 이용하려고 하는데 지속적으로 -13에러 (permission denied)를 얻어서 해결책을 문의드립니다.

1. stt 헤더파일을 등록 후

2. public 레벨의 certification을 생성했습니다. (생성 후에 특별한 다른 작업 없이 자동으로 app에 권한을 부여하는 것 맞나요?)

3. menifest editor에서 recorder 권한을 등록했습니다. (이것도 등록 이후에 코드작업이 따로 필요없다고 알고 있습니다.)


stt_create 함수에 나와있는 조건을 모두 충족시킨 것 같은데 왜 계속 접근거부가 되는건지 이해할수가 없습니다.

제가 어떤걸 놓쳤는지 알려주시면 정말 감사하겠습니다.

Edited by: MINSEOUNG CHO on 05 Nov, 2018


4 Replies
Yasin Ali


Would be please tell which device you are working on.


I just use Tizen emulator in my laptop now.  (wearable 4.0)


I think tizen emulator can't access recorder resorce in my laptop... because Tizen emulator also has recording fail at Tizen recorder sample.

(my laptop don't use AC97 sound device.. Is the couse of error the HD sound device of my laptop?)


and My another question is that will I not have a same error if I use real watch device? (for example new version of galaxy watch)


So.. If you know answers about my question, tell me them.. I really hard on this account. Thank you.


Yasin Ali

Please check
for tizen-studio prerequisites such that everything is there to run.
As far as I know it is best to test your app in real device. Sometimes it may cause some problem with real one
while emulator having no problem.


Hi I solved problem that I had encounterd.

Who has problem what I had, you't better use functions

void app_check_and_request_permission(appdata_s *user_data) and 
void app_request_response_cb(ppm_call_cause_e cause, ppm_request_result_e result, const char *privilege, void *user_data).
In tizen, the privilege about user privacy must need user permission. Not just enroll to menifest.xml, you must add these functions to your code.

I hope my experience to solve this problem should help somebody who encounters same problem.