Languages

Menu
Sites
Language
Native service packaged with native watch face

Hello, is there any way how I can package a native service into a native watch face?

When I use multi package, the watch face cannot be set. I do not receive any error in logs, when I set a breakpoint to the beginning of the main function in watch face, it never reached that breakpoint, so the watch face is not getting started at all.

When I removed the service from the package, it works well. I also tried it with freshly created, empty service, and my service is tested with other native app where everything works like it should, so there is probably no problem in the service, nor the watch face.

I have every privilege I need.

 

I am getting really frustrated developing on this platform, the IDE is awful and slow as hell, I have to restart emulators or even physical devices too often...

Responses

4 Replies
Shaswati Saha

The reason behind this is Watch Applications can't be launched by the Debug As option. There's no problem with your applications I guess. Please go through this link to debug watchface app. Hope it'll help you.

Vydra

thank you, however, Debug as was kind of "last resort" option in this case,

Before debugging, I've tried to install it normally several times and it did not work both on emulator or physical gear s3 device.

Interesting thing is, that when I run it on physical device (via Run as), it starts somehow like a normal app (when I press the back button, it exits and goes to normal watch face that is set). The problem occurs only after I try to set it as watch face.

So I will try to summarize it, if it is not clear.

  1. I run the app (via Run as command)
  2. It launches like a normal application and everything works like a charm
  3. I close it
  4. I try to set it as watch face
  5. Device freezes for 2-3 seconds
  6. Previous watch face appears
Shaswati Saha

I've tried to test this scenario with watchface and service app(both wearable 2.3.2) into my Gear S3 (Tizen version 3.0.0.1) and yes you're right. Watchface doesn't launch if it's packaged with a native service app. May be it's a bug. According to this link, watchface app is allowed to package with multiple service app.

Vydra

Thank you for your time, probably it is a bug. I will check if it has been reported and report it if it has not.