Languages

Menu
Sites
Language
Unable to Login to Samsung Account and Create Samsung Certificate

After uninstalling Tizen Studio 3.3 and updating to Tizen Studio 3.5, I re-created my Samsung Certificate so I can install and test my Native app on a Samsung device. After completing the 4 steps of creating the certificate in the certificate manager and attempting to login to my Samsung account I get a "Failed to parse response. Please try to login again" page. Currently running Windows 10 x64, Java 8, Tizen Studio 3.5. I have tried re-installing Tizen Studio 3.5, installing Java openJDK 12, checking environment variables, restarting computer, but nothing has worked. Any help would be appreciated.

 

 

Edited by: Liam Wilburn on 03 Nov, 2019

Responses

2 Replies
Liam Wilburn

Reverting back to Tizen Studio 3.3 and Java 8 didn't to work either...

  • Change JAVA_HOME path back to the Java 1.8 directory
  • Restart computer
  • Open the Tizen package manager
  • Select Configuration (cog button)
  • Turn off auto update
  • Select Tizen 3.3 (it will uninstall everything)
  • Reinstall everything

Is this a Samsung Account problem or is Tizen Studio incorrectly parsing the response from  he Samsung Account API?

Liam Wilburn
{
    "access_token": "<<access-token>>",
    "token_type": "bearer",
    "access_token_expires_in": "796812",
    "refresh_token": "-1",
    "refresh_token_expires_in": "-1",
    "userId": "<<user-id>>",
    "client_id": "4fb7fnf3np",
    "inputEmailID": "<<my-email-address>>",
    "api_server_url": "eu-auth2.samsungosp.com",
    "auth_server_url": "eu-auth2.samsungosp.com",
    "close": true,
    "closedAction": "signInSuccess"
}

Looking futher into the sign in request...

  • Going to: https://account.samsung.com/accounts/TDC/signInGate?clientId=4fb7fnf3np&tokenType=TOKEN is the same as the site hosted by the certificate manager when asked to sign into your smasung account
  • After logging in, you are directed to a page that just shows a JSON object as shown above (I have censored some of the details)

The JSON object looks valid and everything seems fine... Hopefully this helps in determining what's wrong and why Tizen Studio can;t parse the response.