Problem flashing RD-PQ to 2.2 Tizen


I have a RD_PQ device with tizen 2.1 firmware. As I want to develop a bluetooth app, I need to update to 2.2. So I tried.

At first (after a few trials) I could run the following command with SUCCESS:



lthor Tizen_RD-PQ_System_20130716_1.tar


Then I tried  to run the other lthor commands for the core application and it didn't work anymore. Now it alwayssays this:


$ lthor tizen-2.2_20130719.3_RD-PQ.tar.gz
Linux Thor downloader, version 1.3 
Authors: Jaehoon You <>
USB port is detected : /dev/ttyACM0
tizen-2.2_20130719.3_RD-PQ.tar.gz :
[ums.img] 123136k
[platform.img] 862740k
[data.img] 129616k
total : 1089.35MB
line 299: failed to receive data r = 0
RQT_DL_INIT, status = ffffffff

I've tried, with the same results, in Ubuntu 12.04 64 bits, Ubuntu 12.10 64 bits and on Opensuse 12.3 64 bits. As it is suggested here, I've tried removing/stopping the modemmanager, with no success.



Edited by: Brock Boland on 17 Mar, 2014 Reason: Paragraph tags added automatically from tizen_format_fix module.


1 Replies
muditha murthy
Check this link:, if this could help u