Languages

Menu
Sites
Language
Flash Tizen image to TM1 failed

When I flash Tizen image from  http://download.tizen.org/releases/2.4/2.4-mobile/tizen-2.4-mobile_20151030.1/images/ to TM1 (got from TDC Shenzhen) according to the guide, lthor reported "success", but TM1 restarted again and again, stoped at Tizen logo every time.

Why? How to fix? Can anyone help me?


Thanks a lot.

Responses

20 Replies
Peter Wegner

I have no TM1...

But I saw this problem before with 1 TM1... flashed in other way.

So we thought we did big mistake.

 

Now if lthor under Linux can produce same result...

 

Check this Community page also... if nobody answers:

https://samsung.tizenforum.com/?topic=229.15

 

Since this TM1 Firmware is available, only 3 users gave feedback.

 

I hope somebody can help you, or you find solution.

Then please post your solution.

 

Meanwhile checklist.

1.

You are Linux user?

Only stupid question as I have big problems with Linux as Windows Fan boy...

1.1

Linux Version you are using?

Ubuntu, Fedora or others... please with Version

1.2

Live CD or from USB or full installed on PC, Notebook or whatever...

 

Maybe this helps to detect what the problem could be.

I have only 1 idea... because Loop after Logo I saw very often... so something Security related could the reason...

Maybe different TM1 revisions with different Software.. or IMEI/Security related...

 

Good luck.

 

Best Regards
 

key

Peter, thank you.

Yes, I checked that link, and tried his way, issue is still existed.
I think maybe my hardware is different from his, my TM1 is from TDC 2015 Shenzhen, and his from TDS 2015 BGL.

For the checklist:
1.1 Ubuntu 14.04.
1.2. Full installed on PC.

Thank you for your replying. For more help, I will reply that link too.
Hope to get more help.

Peter Wegner

Thanx for confirmation.

 

So solution is not to try more then once...

Are you able to find other users with TM1 from TDC 2015 Shenzhen?

Maybe somebody was able to update successfully? Or maybe untouched can compare few infos...

Here you can find few hints...

https://developer.tizen.org/forums/general-support/tm1-dev-device?tab=active

 

We have "full backup" before full 8 GB... with dd...

I will try to compare uboot... maybe partition table...

 

Best Regards

 

key

Maybe I'm the first to flash. Others don't want their devices to be dead, after they know my story.

 

There is a clue.

In download mode, there is a white line "HW REV: 1" below the red line "THOR MODE".

Is it valuable for proper image?

 

Peter Wegner

http://download.tizen.org/prerelease/tizen/mobile/tizen-mobile_20151202.4/tizen-mobile_20151202.4.20151202.111149/images/target-TM1/mobile-wayland-armv7l-tm1/

 

This time Kernel inside...

Before I never saw TM1 package with Kernel...

 

Warning... this is Tizen 3.x tests...

 

Not tested....

 

Risk should be "low"... TM1 will not explode...

as uboot (Bootloader) is not inside.

 

Own risk!

 

Best Regards

key

Thank you.

But your link is not existed, I tried another:
http://download.tizen.org/prerelease/tizen/mobile/tizen-mobile_20151202.4/tizen-mobile_20151202.4.20151202.065613/images/target-TM1/mobile-wayland-armv7l-tm1/

But failed during downloading.

Then TM1 return to loop restart.

Peter Wegner

Thanx for feedback.

Do you remember if old uboot Bootloader shows this info too about:

HW REV: 1

Maybe this is feature of new uboot...

Sorry, I found only Picture without this Info... and I have no TM1 to check self.

Maybe other users can help/confirm...

 

About Link to EXPERIMENTAL Tizen 3.x Firmware...

Its under heavy Development and not really for public tests... so they change/remove and add and not documented...

As an kind of "protection"... rootfs.img is much BIGGER as TM1 can handle...

 

If you used other package...

Check if Kernel is inside:

dzImage

 

In most packages before... I have downloaded few...

Kernel was missing too...

 

Best Regards

 

 

Peter Wegner

Sorry, I have no progress...

 

My second tester also not answer...

 

Maybe meanwhile you found solution...

 

Best Regards

Peter Wegner

Oh... interesting...
tizen-mobile_20151209.2_mobile-wayland-armv7l-tm1.tar.gz

This time rootfs.img is not more 1800 MB...
Shrinked to 900 +...

No idea if this is correct size for old partition table...
But also here Kernel inside...

Only as info...

 

Best Regards

 

Peter Wegner

Looks like new package for TM1 available... (Tizen 2.4)

http://download.tizen.org/snapshots/2.4-mobile/common/latest/images/target-TM1/

https://wiki.tizen.org/wiki/Flash_Tizen_2.4_Image_to_Reference_Device

 

It is from snapshot folder...

The first and only public package still in release folder:

http://download.tizen.org/releases/2.4/2.4-mobile/tizen-2.4-mobile_20151030.1/images/target-TM1/

 

Only as info.

Best Regards

Peter Wegner

Hey key you are alive?

Did you find meanwhile solution?

Tried to contact you... but you never answered...

 

Someone flashed latest (March 2016) Firmware?
http://download.tizen.org/releases/2.4/2.4-mobile/latest/images/target-TM1/mobile_target-TM1/

Please any kind of feedback is welcome.
tizen-2.4-mobile_[b]20160307.1[/b]_mobile_target-TM1.tar.gz

Thanx in advance.

Best Regards

key

Hi Peter, sorry for replying late.

I tried the firmware you shared, but failed again.
I almost give up.

Now I'm using another one which hardware version is 0.
I can flash 2.4 firmware to it easily, both the latest and old.
I can't understand why my hardware's version is so different.

Anyway, thank you to track my issue so long.
If the issue only occured to me, please ignore it.

Philippe Coval

Hi,

I own a TM1 and wrote this page with some tips and tricks :

https://wiki.tizen.org/wiki/TM1

Mine still have the original fw (from TDC2015) , but I am facing issue to deploy apps using current SDK.

If you have the device and want to share data, please add your contact to community section of that page or tell me your contact, I can add if for you...

I hope we'll become more effecient if working together on that unit

 

Peter Wegner

Thanx Phillipe Coval.

 

I have no TM1, otherwise I would share my experiences.

 

 

@key

Thanx for info.

You are not the only user with such phenomen...

Before 1 other user... but I lost contact....

And no idea if he fixed problem meanwhile...

 

Did you tried Tizen 3 Wayland Firmware with this special TM1 device?

http://download.tizen.org/prerelease/tizen/mobile/

Maybe this work to have access again...

Then in theory restore via SDB maybe possible... after you dump all partitions of working TM1...

 

No April fool.

 

Best Regards

Jaehoon Chung

Hi Guys,

Sorry for answering too late. I didn't check this page..(it's my fault)

Did you fix this problem?

I have fixed this issue on the bootloader side. Your target might be flahsed u-boot as bootloader.

Could you flash the below image?

http://download.tizen.org/snapshots/2.4-mobile/common/latest/images/target-TM1/mobile_target-TM1/

There is u-boot image that is fixed. (u-boot-mmc.bin)

Main problem was that bootloader had calculated the wrong offset. (Refer to the below commit.)

https://review.tizen.org/gerrit/gitweb?p=profile/mobile/platform/kernel/u-boot-tm1.git;a=commitdiff;h=09fc858f66a88d4d152e3ac972e052332b23ba8f

(If you want to use more exactly version, after building u-boot-tm1, you can flash with your built image.)

Following the below sequence:

1. Download the above image

2. Flash the images..(For uploading the fixing bootloader.)

3. Reflash the images..(For uploading the other images with the fixed bootloader.)

4. Booting.

If you have any question or problem, let me know, plz.

Again..Sorry for checking too late.

 

Best Regards,

 

Peter Wegner

Dear Jaehoon Chung.

 

1.

Thank you very much for answer.

I have no TM1 so I can't test self.

 

2.

Since few months... years I ask my self why lthor only as Linux Version available...

I can remember 2x RD-PQ click Windows Versions were available during Portathon... loooong time ago.

 

Ehm... Now I am using the "first few Bytes" successfully with RD-PQ... with different TARs inside...

To calculate MD5 is not real big deal...

Example with OLD TM1 Firmware from November 2015...

http://www.mediafire.com/download/f6qfffxeyjn95k3/TM1testTHORv1.zip

Not self tested, but Flashing TM1 was successfully.

Output looks like this:

<ID:0/003> Initialzation..
<ID:0/003> NAND Write Start!!
<ID:0/003> dzImage-recovery
<ID:0/003> rootfs.img
<ID:0/003> user.img
<ID:0/003> system-data.img
<ID:0/003> dzImage
<ID:0/003> u-boot-mmc.bin
<ID:0/003> Removed!!
<ID:0/003> Completed..
<OSM> All threads completed. (succeed 1 / failed 0)

Maybe 1 day in future please release Windows Tool in public...

As it seems not all Users are able to flash easily with Linux...

 

Thanx in advance.

 

Best Regards

Mats Wichmann

I can confirm I got this image to do the trick.

 

Peter Wegner

Thanx Mats Wichmann for feedback.

Please, can you tell me with which Windows Version you did it?

 

Thanx in advance.

 

Best Regards

Andrea Jones

This is a very technical question that will surely be answered by professionals logo designer or a developer who is experienced in working with such kind of environment. I hope you will get your answer as soon as possible 

Best Regards