Device Manager doesn't find certificate profiles
I'm trying to get developing for the Samsung Galaxy Watch. The Device Manager sees my device. Next thing is right-clicking the device, and choose "Permit to install applications". Then there's a message about creating a certificate profile. I have made a certificate profile already, (several times, several options picked, etc) but it just doesn't get picked up by the device manager. I'm on Windows 10 1809. Am I missing something? Thanks in advance for helping me out!


6 Replies
K Johnson

Please try installing the app keeping certificate profile for that device active from certificate manager. Just skip the "Permit to install applications" step and check whether it works in your case or not. Please check below image to set a certificate profile active.


Matthijs ter Woord

Sadly hitting Run in Visual Studio 2017 errors with "Check certificate error [-12] failed"



K Johnson

Would you please try following below steps?

# Step 1: Delete all the existing certificates.

# Step 2: Set the Correct Date & Time in both device and PC. In your device, Turn on USB Debbuging.

# Step 3: Connect the device, Accept connection request in device end. make sure it's on your connection explorer in Tizen Studio.

# Step 4: Create new Author certificate, Distributor certificate, Add the device, Set the Profile active.

# Step 5: Clean, Build & Deploy project.

Juwon(Julia) Ahn

Tizen Studio Device Manager >> "Permit to install applications"

 Regarding this, you don't need to do this step because your device is Galaxy Watch model. As far as I know, Galaxy Watch's DUID starts with "2.0#", not "1.0#".

You can get detailed information about it from here :

If you face certificate error when installing your .NET application, please check the following things.

   1.  use the DUID of your Galaxy Watch device when you create Samsung Certificate profile.


   2.  use your Samsung Certificate profile when you build your .NET application

          (Visual Studio 2017 >> Tools >> Options >> Tizen >> Certification)



<How to create a Samsung Certificate Profile>



cola kamornik

Juwon You are great ! Your paragraph 2 - solved WEEK of my suffer and reading almost every topic with "Certificate" in it .... 

have no idea why it is not automatically set for me - but think it definitely should be mentioned in Documentation... browsed it few times - never seen it there... and the small (i) is also very not obvious that after ticking it - it is applied automatically  only to NEW solutions... just imaging how many people created solution->tried -> tried on Emulator -> tryed to move to real device-> created the Certificate -> tryed to run on device and got stuck.....

as i did...

Damian Antonowicz

I also agree that information about certification settings (in Tools > Options > Tizen > Certification) should be in documentation. I was struggling with installing my app on device and the problem was that certification settings were missing.