Check certificate error [-12] failed

C:\tizensdk\tools>sdb install C:\Users\jh\source\repos\PleaseInstall\PleaseInstall\bin\Release\tizen50\org.tizen.example.PleaseInstall-1.0.0.tpk

WARNING: Your data are to be sent over an unencrypted connection and could be read by others.
pushed org.tizen.example.PleaseInstall-1.0.0.tpk        100%        466KB           0KB/s
1 file(s) pushed. 0 file(s) skipped.
C:\Users\jh\source\repos\PleaseInstall\PleaseInstall\bin\Release\tizen50\org.tizen.example.PleaseInstall-1.0.0.tpk   136KB/s (478165 bytes in 3.411s)
path is /home/owner/share/tmp/sdk_tools/org.tizen.example.PleaseInstall-1.0.0.tpk
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[start] val[install]
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[install_percent] val[9]
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[install_percent] val[12]
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[install_percent] val[15]
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[install_percent] val[18]
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[install_percent] val[21]
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[install_percent] val[25]
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[error] val[-12] error message: :Non trusted certificate is used. Register valid certificate:<-32>
__return_cb req_id[1] pkg_type[tpk] pkgid[org.tizen.example.PleaseInstall] key[end] val[fail]
processing result : Check certificate error [-12] failed
spend time for pkgcmd is [1341]ms


There is nothing to be dissatified with the resolution of the problem presented when searching for this issue.

but I am still having problems.


1. It is wirelessly connected to the gear and is looking at the log.

2. made with Samsung certificate.

3. When I created the certificate, duid also displayed and registered properly

4. The 'Permit to install applications' is not required for this device.


I would like to try installation only.

My project name is PleaseInstall :(

What more should I do?

Edited by: steve yang on 31 Mar, 2019
View Selected Answer


6 Replies


1. did you check the current default security profile setting on certificate manager?

2. and confirmed that the package is signed with the correct security profile?

3. Is gear device firmware up-to-date?

If you checked the above things and everythings are sure, try clean build again.

steve yang

1. I have a single certificate and it is checked

2. you can see "is signed with Default Certificate!"  

3. I just checked firmware version and it's the latest version



while  looking at the firmware, I noticed that "Unknown app installs" was not checked in the app

so I expected it to be fixed, but it also failed :<


Mark as answer

looks strange.

here are few things you may try.

1. build and packaging your app using Tizen CLI interface. you may try this to make it sure that signing was done properly. the "tizen" CLI is under "tizen-studio/tools/ide/bin".  For windows, use "tizen.bat" I think. (my environment is ubuntu).

For the .NET project, the build command should be like the following

tizen build-cs -- <your project folder path> -s <your security profile name>

In the build log, you should verify security profile name which is used for signing your package.

2. install the package using Tizen CLI interface rather than "sdb" command.  Depends on platforms, sometimes "sdb install" command does not work properly.

tizen install -n <package path name>



steve yang

When i build it as a VisualStudio, It failed

and I succeeded in building it using tizen.bat

Thank you for your help

Joel Page

Here is the page that helped me. I had the same problem but don't want to build from tizen.bat every time. The solution in the above document that worked for me was to close Visual Studio and open the *.csproj file in my solution then add the following replacing with the directory of the certificates I created and my passwords:


Just put it below any other Property Group tags. Open Visual Studio again and it should build using the certificate.

Pistle Potter
To Handle Error 'certificate error [-12]'

You must ensure that the . NET application is signed with your Samsung certificate profile, not the Tizen default certificate. To use your Samsung certificate profile: Navigate to Visual Studio > Tools > Option > Tizen > Certification.