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Prerequisites for the Tizen SDK 



The following table lists the operating systems supported by the Tizen SDK. 

Operating Systems 
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OS Version Bit 

Ubuntu 14.04/12.04 32 and 64 

Microsoft Windows® 8/7 32 and 64 

Mac OS® X 
10.10 (Yosemite) / 10.9 

(Mavericks) / 10.8 
(Mountain Lion) 

64 

System Requirements for Tizen SDK 

For more instructions on how to check the system specifications, see 

Appendix: Checking System Specifications (pages 83-84). 

  



The following table lists the processor and memory requirements for the 

Tizen SDK. 
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Component Minimum Recommended 

Processor Speed 2 GHz 3 GHz and above 

Processor Type Intel Dual-Core Intel Core i5 and above 

Memory 3 GB 4 GB and above 

Disk Space 6 GB free 6 GB and above  

Processor and Memory System Requirements for Tizen SDK 

Note 

The Tizen SDK can be installed on AMD processors, but may not perform properly due 

to absence of the Intel Hardware Accelerated Execution Manager (HAXM), which 

accelerates the speed of Tizen application emulation. 
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The following table lists the CPU and screen resolution requirements for 

the Tizen Emulator. 

Component Requirement 

CPU 
Recommended: support for Intel VTx* 

(Virtualization Technology) 

Screen resolution Recommended: 1280 x 1024 

System Requirements for Tizen Emulator CPU & 

Screen Resolution 

* For more instructions on how to check for Intel VTx support, see 

Appendix: Checking CPU VTx Support (pages 85-86). 
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The following table lists the Graphic Card requirements for the Tizen 

Emulator. 

Brand Product 

NVIDIA 
GeForce 8300 GS, GeForce 8500 GT, GeForce GT 220, GeForce GT 430, 
GeForce GT 530, GeForce GT 330M, GeForce GTX 550Ti, Quadro NVS 

290 and later versions 

ATI RADEON HD 4850, RADEON HD 5450 and later versions 

Intel 
HD Graphics 2000, HD Graphics 2500, HD Graphics 4000  

and later versions 

Graphics Card 

For more instructions on how to update the graphic card driver, see 

Appendix: Checking and Updating the Graphic Card Driver (pages 87-

88). 

  

System Requirements for Tizen Emulator 



Tizen SDK requires the JDK (Java Development Kit) installation for using the 

Java Runtime (VM).  

 

Java 7 or higher is required for the Tizen SDK to work properly, and as of 

January 2016, it is recommended to install Oracle JDK 8 for the Tizen. 

 

Do not install Open-JDK. 

 

Java Development Kit (JDK) 
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JDK Requirements 

Note 

Tizen SDK is a development tool based on the Eclipse IDE, which essentially requires  

the JDK installation as well. 

For instructions on how to check and uninstall the existing JDK in your 

system, see Appendix: Checking and Uninstalling the JDK (page 89). 

  



Download Oracle JDK 8 from http://www.oracle.com/technetwork/java/ 

javase/downloads/jdk8-downloads-2133151.html. 

 

1. Select Accept License Agreement . 

2. Download the installer (.exe file) according to your system environment. 

Downloading the JDK 
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JDK Requirements 

Choose the 

right version, 

32bits (x86) or  

64bits (x64). 

Click 

http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/ javase/downloads/jdk8-downloads-2133151.html
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Installing the JDK JDK Requirements 

Install the JDK by following the instructions. 

Do not change the installation folder from the default location. 

Click 
Click 

Click Click 



Tizen SDK Installation 
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Tizen SDK Installation Downloading the installer 

For more information about the IDE and CLI options, see Appendix: Tizen 

SDK Installation Options – IDE and CLI (page 90). 

  

Download Tizen SDK installer from https://developer.tizen.org/downloads. 
 

Choose the Tizen SDK installer (IDE) according to your system environment. 

Select 
32bits or 64bits 

https://developer.tizen.org/downloads
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Installing the Tizen SDK 

Double-click on the installer (.exe file), and the installer starts verifying the  

system  

requirements prior to the installation of Tizen SDK. 

Tizen SDK Installation 

Double-Click 



If the JDK is not installed on your computer, the following pop-up appears. 
 

Click OK and install the JDK before installing the Tizen SDK. 
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Installing the Tizen SDK 

For more information about the JDK requirements and how to install JDK, 

see JDK Requirements (page 7-9). 

Tizen SDK Installation 

Click 



When the installer window appears, start installation by following the steps: 

 

1. Accept the Software License Agreement. 

2. Confirm the Installation Location. The directory must be empty. 

3. Click the Install button on the right to continue. 
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Installing the Tizen SDK Tizen SDK Installation 

(1) Click  

(3) Click 

(2) 



The installer installs the basic packages (IDE for Web application 

development) for the Tizen SDK. 
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Installing the Tizen SDK 

When the installation is completed, click Done. 

Tizen SDK Installation 

Click 



Run the Update Manager to install additional packages required for the 

development of  Tizen applications.  
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Installing Additional Packages 

Click Yes on the prompt message upon the completion of the SDK 

installation.  

Later, you can launch the Update Manager-<version> from Windows Start 

Menu      > All Programs > Tizen SDK-<version>. 

Tizen SDK Installation 

Click 



When the Update Manager is launched, it shows the All Packages tab, which 

lists all the available packages that can be installed at the moment. 

19 

Installing Additional Packages 

Select a specific platform and profile (2.4 Mobile, 2.3.1 Mobile, 2.3 Mobile, 

2.3.1 Wearable, or 2.3 Wearable) you want to install. 
 

For the purpose of this tutorial, the 2.3.1 Wearable package is used.   

Tizen SDK Installation 



Click the arrow on the left and expand to view the components of the 

package.  

The description of each component is provided at the bottom of the window. 
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Installing Additional Packages Tizen SDK Installation 



For the purpose of this tutorial, install all components of the 2.3.1 Wearable 

package by clicking Install. 
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Installing Additional Packages Tizen SDK Installation 

Click 



The update manager automatically detects and installs any dependent 

packages required. 
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Click Yes to automatically install all the required packages. 

Installing Additional Packages Tizen SDK Installation 

Click 
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Installing Additional Packages 

Select the Progress tab to view the detailed progress of the installation. 

Do not switch off the update manager while it is downloading and installing  

packages. Downloading and installing may take a few minutes. 

Tizen SDK Installation 



The Install button changes to Installed when the packages are installed. 
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Installing Additional Packages Tizen SDK Installation 



Confirming and Removing Packages 
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Select the Installed Packages tab to confirm the installed packages.  

You can also remove a package if you want. 

Tizen SDK Installation 
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To uninstall the entire Tizen SDK, launch the SDK Uninstaller-<version> 

from Windows Start Menu      > All Programs > Tizen SDK-<version>. 

 

Uninstalling the Tizen SDK Tizen SDK Installation 



Running Applications on the Emulator 



Launch Tizen IDE-<version> from Windows Start Menu      > All Programs 

> Tizen SDK-<version>. 
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Launching the Tizen IDE Running Applications on the Emulator 

Click 



The Tizen IDE is launched successfully. 

Launching the Tizen IDE 

29 

Tizen IDE is a branded version of the Eclipse IDE. 

Running Applications on the Emulator 



Tizen IDE is composed of the following sections. 

Launching the Tizen IDE 

30 

Project  
Explorer 

Connection  
Explorer 

Outline 

Property 

Problem / Console 

Edit 

Toolbar 

For more information about each section, see the Appendix: Tizen IDE 

Views (page 99). 

Running Applications on the Emulator 



In this tutorial, a Tizen Web application project is created. 
 

Go to File > New > Tizen Web Project. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the  
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



The New Tizen Web Project pop-up appears, and there are 3 project types 

you can choose from. 
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For more information about each project type, see Appendix: Tizen SDK 

Project Types (pages 100-102). 

  

Running Applications on the Emulator 

Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 
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Running Applications on the Emulator 

Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

In the New Tizen Web Project pop-up window, (1) select the Template tab,  

(2) select WEARABLE-2.3.1 > Basic template application, (3) enter the 

project name as “myFirstApp”, and (4) click Finish 

(2) Click 

(4) Click 

(1) Click 

(3) Enter Name 



The new project is created and shown in the Project Explorer. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 



1. Click the arrow on the left of the project name to expand and view the file 

structure. 

2. Click the arrow on the left of a folder to expand and view files inside the 

folder. 
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Running Applications on the Emulator 

Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Click 

Click 



To install and run applications on devices, you must sign the application 

package by generating a vendor-specific certificate and registering it in the 

IDE. (The certificate policy may vary between different vendors and/or 

models.) 

 

Since an emulator is a pseudo device as well, applications to be installed 

and run on the emulator must also be signed with certificates generated from 

the Tizen SDK. 

 

Security profile is a tool for managing certificates and it helps generating, 

registering, and activating certificates in Tizen SDK. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 



Open Window > Preferences to set a security profile for generating 

certificates. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



Running Applications on the Emulator 

Go to Tizen SDK > Security Profiles, and click Add. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

(1) Click 

(2) Click 

(3) Click 



Enter a profile name and click OK.  
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



Set the profile active by clicking Set Active. 

If there is only one profile on the list, the profile is automatically 

set active. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



Running Applications on the Emulator 

Click Generate. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Click 



Running Applications on the Emulator 

Fill in the information in the Certificate Generator. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the  
Application on the 

Emulator 

Click 



Click Yes to fill the author certificate information automatically. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



Security profile has been registered successfully. Click OK. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



Launch the Emulator Manager by clicking the icon       in the Connection 

Explorer. 

 

 
 

Click Create New Emulator > Wearable. 
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Launch an Emulator instance. 

Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 

Click 



Click Confirm. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



Click the play button to launch the emulator instance. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



The Emulator is launched in its own window, and the structure of the 

emulator is shown in the Connection Explorer. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 



Right-click on the project title, and select Run As > Tizen Web Application 

while the Emulator display of the is switched on. 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 

Running Applications on the Emulator 

Click 



The application is launched in the Emulator successfully. 

Running Applications on the Emulator 
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Creating the 
Application Project 

Generating the 
Author Certificate 

Creating the 
Emulator Instance 

Running the 
Application on the 

Emulator 



Running Applications on the Target Device 



The Certificate Extension is an extra package of Tizen SDK. It is required for  

generating an author certificate for commercial devices, such as Samsung 

Gear S2, and registering it in the IDE. 
 

To install the Certificate Extension, close the IDE, and launch Update 

Manager-<version> from Start > All Programs > Tizen SDK-<version>. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



In All Packages tab, click the arrow on the left of Extra and expand to see the 

Certificate Extension. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



1. Click the Accept checkbox to accept the EULA (End User License 

Agreement). 

2. Click Install. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 
Click 



If any of the SDK programs are still running on the system, the following 

pop-up appears. 
 

1. Click OK, and close all the SDK programs. 

2. After closing all the programs, click Install. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 

Click 



Close the Update Manager when the Certificate Extension is installed. 

Running Applications on a Target Device 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 



For Gear S2, you must connect the device to the computer using Wi-Fi. 

For devices that can be connected using USB cable, you can simply connect 

the device to the computer with an USB cable. 

 

For connecting a Gear S2 device using Wi-Fi: 

Running Applications on a Target Device 

57 

Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

1. Switch on the Debugging mode in Settings > Gear info. 



3. Switch on Wi-Fi in Settings > Connections and note the IP address. 

The device and the computer must be connected to the same Wi-Fi network. 

 

58 

Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

2. Switch off Bluetooth in Settings > Connections. 

172.20.10.13 

Running Applications on a Target Device 



Launch the Remote Device Manager by clicking the icon      in the 

Connection Explorer and click New. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 



Fill in the information about the device and click Add. 

Select the device to connect and click Connect button. 
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Click Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 



In the first attempt, the connection can fail. In this case, a pop-up appears in 

the device. 
 

Click the check button to allow Gear to install apps in the device manually. 
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In the Connection Explorer, note that the device is connected successfully. 

Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 



Click the Certificate icon       to generate and register a developer certificate. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



Click New to create security profile. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



Name the profile and click OK. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



Select Crete new certificate to create an author certificate. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



Fill in the information and click Request. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



Click OK. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



Sign in with your Samsung account. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 



Click OK. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 

Select Crete new certificate to create a distributor certificate. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Enter the Device ID and click Request. 

You can cope the DUID from the list on the right. 

Click 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click OK. 

Click 



Sign in with your Samsung account. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click OK when the device has been registered successfully. 

Click 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 

Click OK. 

Click 



Right-click on the target device in the Connection Explorer, and  

go to Permit to install applications. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 



Click OK when the upload is completed. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Emulator 

Running Applications on a Target Device 



Right-click on the project title, and select Run As > Tizen Web Application 

while the Emulator display is switched on. 
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Installing the 
Certificate 
Extension 

Connecting the 
Target Device 

Generating the 
Author & Distributor 

Certificates 

Running the 
Application on the 

Target Device 

Running Applications on a Target Device 



Appendix 



You can view a summary of important information about your computer 

and operating system by clicking Windows Start Menu      ,  right-clicking 

Computer, and clicking Properties. 
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Checking System Specifications OS, Processor, and Memory 

OS 

Processor 
Memory 

OS 



You can check the available disk space by clicking the Windows Start 

Menu      > Computer. 
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Disk Space Checking System Specifications 
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Download the SecurAble.exe file from http://securable.en.softonic.com/ 

and execute the software. 

CPU VT supported  
and HAXM available 

CPU VT not supported  
and HAXM NOT available 

VT supported  
but locked on by BIOS 

(BIOS setup required) 

VT supported by CPU  
but locked off by mainboard 

 

Checking the CPU VTx Support SecurAble.exe 

http://securable.en.softonic.com/
http://securable.en.softonic.com/
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You have to set the VT option to enabled in the BIOS menu. 

The entrance point of the BIOS menu depends on the type of the PC 

mainboard. 

CPU VT supported  
but NOT controllable in BIOS 

CPU VT supported 
and controllable in BIOS 

VTx Option in BIOS Checking the CPU VTx Support 
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Checking and Updating the Graphic Card Driver Windows Update 

You can check your graphic card driver in your system by clicking 

Windows Start Menu      , right-clicking Control Panel, and clicking Adjust 

screen resolution > Advanced Settings. 
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You must update to the latest vendor-provided version of the graphic card 

driver for OpenGL ES acceleration to use the Tizen Emulator. 

 

• For Microsoft Windows® 8/7, check and install the necessary drivers 

in Control Panel > System and Security > Windows Update. 

Windows Update Checking and Updating the Graphic Card Driver 



Confirm the JDK installation in Control Panel > Programs >  

Programs and Features. 
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Programs and Features Checking and Uninstalling the JDK 



The Tizen IDE (Integrated Development Environments) provides a 

development tool with based on the Eclipse IDE. 

• Provides GUI editor and analysis tools with an excellent UX 

• Easy for general users and developers 

• Requires relatively high system resources 

 

The Tizen CLI (Command Line Interfaces) provides an environment for 

creating, building, and packaging projects by using commands on a 

terminal. 

• Suitable for high-level developers with automated build system 

• Requires relatively low system resources 
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Tizen SDK Installation Options IDE and CLI 
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You can change the package server, upload a custom SDK image, change 

the proxy settings, and add extra repositories in the Advanced 

Configuration. 

Advanced Configuration Tizen SDK Installation Options 
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You can install or update the Tizen SDK by using one of the following options. 

• Configuring the Package Server 

1. In the combo box at the top, select Package Server.  

2. In the text box, type  an available repository address and click Refresh.  

3. In the Distribution box, select the distribution you want to download.  

4. Click Confirm. 

Advanced Configuration Tizen SDK Installation Options 
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• Configuring the SDK Image 

1. In the combo box at the top, select SDK Image.  

2. Click the folder icon, browse to the SDK image file, and click OK.  

3. Click Confirm. 

You can install or update the Tizen SDK by using one of the following options. 

Advanced Configuration Tizen SDK Installation Options 
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You can configure a proxy to connect to a repository server. 

 

1. Click the Proxy Settings tab. 

2. Select the configuration you want to use. 

3. If you select Manual Proxy Configuration, enter HTTP Proxy and Port in 

the fields. 

4. Click Confirm. 

Advanced Configuration Tizen SDK Installation Options 
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The Tizen SDK supports extension packages, called extra repositories, 

contributed by external developers and companies. 

To add an extra repository, click the Extra Repository tab and click Add. 

When the Add Repository dialog appears, enter the Name and Repository in 

the fields. The repository indicates the external server address. 

Advanced Configuration Tizen SDK Installation Options 
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To remove an extra repository, click the Trash icon for the repository in the 

table, and click Confirm. 

If the external repository is removed, the packages from the external repository 

are deprecated. 

Advanced Configuration Tizen SDK Installation Options 
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To modify an extra repository, click the target repository and click Modify in 

the table. 

When the Modify Repository dialog box appears, modify the Name and 

Repository fields. The repository indicates the external server address. 

You can also click the folder icon on Repository to select a local image file or 

local server location. 

Advanced Configuration Tizen SDK Installation Options 



To activate or deactivate an extra repository, select the check box of the 

repository to be activated, or clear the check box of the repository to be 

deactivated. 

Advanced Configuration Tizen SDK Installation Options 

95 
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Tizen IDE Views 

• The Project Explorer view provides a hierarchical view of all resources in 

the workspace. You can open files for editing, or select resources for 

operations, such as building, packaging, signing, or validating an 

application. 
 

• The Connection Explorer view shows the devices connected to the system. 

A list of connected devices is available after connecting a device or 

launching a Tizen Emulator with a tree view. 
 

• The Outline view shows the structure outline and Object hierarchy of 

C/C++ and Javascript 
 

• The Property view shows the property of selected files on Project Explorer, 

such as file path, size, editability, and name. 
 

• The Problem view shows the status of build and packaging error or 

warning. 
 

• The Console view shows the target or emulator log when applications are 

run. 
 

• The Edit view is the code editor area. 
 

• The Toolbar provides various shortcut icons for building and debugging. 

 



The Template tab provides a list of templates with basic structure the 

developers can use to create their own Web application project. 

Tizen SDK Project Type Template 
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The Online Sample tab provides a list of sample applications demonstrating 

the usage of various APIs and UI design which developers can refer to. 

Online Sample 
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If the list of online samples does not appear properly, see Appendix: Custom 

Network Settings (pages 103-104). 

Tizen SDK Project Type 



The User Template tab provides a list of user-customized templates that can 

be used as a basis for creating other projects. 

User Template 
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Tizen SDK Project Type 



If the list of online samples does not appear properly, you may have to 

change the network settings. 

 

Go to Window > Preferences > General > Network Connections and change 

the Active Provider option to Manual. 

 

Custom Network Settings (for in-campus use only) 
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Select HTTP and click Edit. 
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Change the proxy setting accordingly  

For the Seoul R&D campus, the host: 10.112.1.184 and the port is 8080. 

Do the same for HTTPS  and click Apply. 

Custom Network Settings (for in-campus use only) 



Right-click on the Emulator screen to view more options on the Emulator. 

Click Control Panel. 

Emulator Control Panel Emulator 
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In the Emulator Control Panel, developers can create and use any data 

required during application execution and imitate environmental conditions 

for the device sensors. 

Emulator 
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Emulator Control Panel 



You can adjust the screen timeout of the emulator in Settings > Display > 

Screen timeout. 

Screen Timeout on the Emulator 
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Swipe-up 
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You can troubleshoot your Tizen SDK installation by referring to the 

installation log file. The log file is located in a different directory based on 

your operating system: 

• Windows® 7: %LOCALAPPDATA%\.installmanager\install-log 

• Windows® XP: %USERPROFILE%\Local Settings\Application 

Data\.installmanager\install-log 

• Ubuntu, MacOS®: $HOME/.installmanager/install-log 

Manual Troubleshooting Troubleshooting 
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If the Install Manager fails to connect to the SDK package server: 

• Check whether you can access the Tizen Web site using the Web 

browser on the system where you are installing the SDK.  

• If not, install the SDK using the SDK image. 

• Check whether you are using a network proxy. If yes, run the Install 

Manager. Click Settings and select the desired option. If the proxy server 

needs authentication, an ID and password dialog appears. 

• The proxy option is not provided anymore. 

Network Connection Failure Troubleshooting 
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When installing the Tizen SDK using the SDK image, you may see the Cannot 

open SDK image file dialog box.  

 

The box is displayed if you are using the JDK1.6 updates 26 JDK. To avoid 

this problem, ensure that you are using the latest version of Java. 

 

See JDK Requirements (pages 7-9) for the JDK installation guide. 

 

 

SDK Image File Dialog Failure Troubleshooting 
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During the Tizen SDK installation, the Java application can crash 

unexpectedly, and the following window is displayed. 

Crashing of Java during SDK Installation  Troubleshooting 

To avoid this problem: 

• Ensure that you are using the latest version of the error DLL file, such as 

MSVCR100.dll. If the error file version is not the latest, upgrade it. 

• Update your system with all the Windows-related updates using 

Windows Update. 
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If the Install Manager does not appear, an error may have occurred in the JDK 

installation.  

 

You can check your problem by following these directions: 

• Run the Install Manager with the -help options. 

 

 

 

• If you see the following message, the Java libraries are not suitable to 

Java executables.  

"Registry key 'Software\JavaSoft\Java Runtime 

Environment\CurrentVersion' has value 'XXX', but 'XXX' is required." 

 

Install Manager Not Appearing Troubleshooting 



The cause is that Java files in System32 do not match the Java Runtime 

Environment in the registry. 

 

To avoid this problem, copy the java.exe file to the  System32 directory.  

 

If Tizen Emulator does not appear when you launch it, you may face the same 

trouble log at <TIZEN-SDK-DATA>/emulator/vms/<Emulator 

name>/logs/emulator.log file. 
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Install Manager Not Appearing Troubleshooting 
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If the Emulator does not work properly, there might be an error in the 

HAXM. 

 

The Intel Hardware Accelerated Execution Manager (Intel HAXM) is a 

hardware-assisted virtualization engine (hypervisor) that uses Intel 

Virtualization Technology (VT) to speed up Tizen application emulation on 

a Windows® or Mac® host machine.  

 

HAXM is supposed to be installed automatically as part of the Tizen SDK 

installation.   

 

However, to install HAXM separately, you can download the Windows 

installer package using the link below: 

http://download.tizen.org/sdk/haxm/1.1.9/win/intelhaxm-tizen.exe  

Troubleshooting 

http://download.tizen.org/sdk/haxm/1.1.9/win/intelhaxm-tizen.exe
http://download.tizen.org/sdk/haxm/1.1.9/win/intelhaxm-tizen.exe
http://download.tizen.org/sdk/haxm/1.1.9/win/intelhaxm-tizen.exe


HAXM 
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HAXM supports the following Windows® versions: 

• Windows® 7 (32/64-bit) 

• Windows® Vista (32/64-bit) 

• Windows® XP SP2 or later (32-bit only) 

 

 

Run the installer and accept the UAC prompt, if you are running the stand-

alone installer. 

 

Troubleshooting 



HAXM 
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When the first HAXM install screen is displayed, click Next. 

Troubleshooting 

You can access the documentation at any time by clicking Intel HAXM 

Documentation. 



HAXM 
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Read and accept the Intel HAXM End-User License Agreement (EULA). 

Troubleshooting 
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You are prompted to adjust the amount of RAM to be allocated to Intel 

HAXM. 

Troubleshooting 

Note 

The installer also functions as a configuration tool for Intel HAXM. To change the 

memory settings, run the installer again. 



HAXM 
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The next screen confirms your Intel HAXM memory allocation settings. 

Click Install to proceed. 

Troubleshooting 



HAXM 
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When the Intel HAXM installation is finished, click Finish to exit the 

installer. 

Troubleshooting 
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To verify that Intel HAXM is running, open a Command Prompt window and 

execute the command: sc query intelhaxm 

 

If Intel HAXM is working, the command will show a status message 

indicating that the state is 4  RUNNING. 

Troubleshooting 
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Starting and  Stopping HAXM 
To stop or start Intel HAXM, open a Command Prompt window with 

administrator privileges and execute one of the following commands: 

• Stop HAXM: sc stop intelhaxm  

• Start HAXM: sc start intelhaxm 

 

Adjusting Intel HAXM Memory Allocation 
To change the amount of memory allocated to Intel HAXM, run the installer 

again. 

 

Troubleshooting 

Note 

Changes to Intel HAXM memory settings take effect when Intel HAXM is restarted. The 

currently running emulators continue to use the previous memory setting. 



HAXM 
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Removing HAXM 
 

 

 

 

To uninstall Intel HAXM, run the installer again or use the Control Panel. 

 

 

Troubleshooting 

Warning 

Close all instances of the Tizen emulator before removing Intel HAXM. 

Important 

Removing Intel HAXM disables the acceleration of all Tizen emulators, but the Tizen 

emulator still functions. Installing Intel HAXM again re-enables the emulator acceleration. 



HAXM 
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Troubleshooting HAXM (BIOS/OS Setting) 
Hardware feature required by HAXM may be disabled by BIOS or OS. If 

your installation fails because of a hardware requirement, please check 

BIOS/OS as followed suggestion: 

• Make sure VT is enabled in BIOS. 

• Make sure Execute Disable Bit is enabled in BIOS. 

• Make sure Data Execution Prevention is enabled in Windows. On the 

Windows platform, click Control Panel > System > Advanced system 

settings > Advanced tab > Performance section, Options (or Settings) 

button > Data Execution Prevention. Make sure that DEP is enabled. 

Troubleshooting 


